QMake crashed while execute libGLESv2.pro



  • Hi.

    I am trying to build angle from the source of qtbase, and when am trying to execute this line: >qmake.exe C:\User\Downloads\qt-everywhere-opensource-src-5.8.0\qt-everywhere-opensource-src-5.8.0\qtbase\src\angle\src\libGLESv2\ libGLESv2.pro I get next error:

    Project MESSAGE: Enabling D3D11 mode for ANGLE
    ASSERT: "!isEmpty()" in file path/to/file/src/corelib/tools/qvector.h, line 235
    

    and after that qmake is crashing.

    Do I need some external library to make this command works?
    Did I miss something?

    Thanks in advance for any help.

    Update: My system is - Windows Server 2016 Standart, Qt Version 5.8.0

    QMake version 3.1
    Using Qt version 5.8.0

  • Moderators

    Have you run configure before attempting to build Angle?



  • Yes, I did. I have run it with next parameters:

    configure -silent -platform win32-msvc2015 -static -no-incredibuild-xge -no-dbus -no-sql-sqlite -nomake examples -angle -nomake tools -confirm-license -no-qmltools -no-harfbuzz
    

    In config.log I can see a banch of errors, but nothing special thought.
    With key -no-angle -opengl desktop everything works as expected.
    Also there is static build, not sure if that important.
    Another thing, that I do not include everything from Qt library, since the politics of project, but I definitely have qtbase/src/angle and qtbase/src/3rdparty/angle directories up to date with qt 5.8.0. Do I need to some more library to make possible to build angle like a part of Qt? Or probably I could somewhere get this info(in some log file, don't find any helpful info), I mean about missing library or probably info why qmake is crashed?
    Thanks


  • Moderators

    I think since Qt 5.7 the default option is -opengl dynamic, which chooses backend automatically at runtime. Not sure (I rarely use Windows), maybe the -angle build has not been checked for 5.8.0 release and it has a bug. It's especially plausible since you also build in static mode.

    Anyway, I'm just guessing. Try the same on Qt 5.9.1 maybe? Also, check the configure output - what it says about OpenGL option chosen (maybe it will tell you that there is some flag "conflict").



  • @sierdzio Thanks for your reply.

    I couldn't update qt to newest version due to lot of works on project, so fix with 5.9.1 unfortunately is not fit for me.
    According to crash, I found the reason there is no Makefile in Qt\qtbase\src\angle\src\libGLESv2(it wasn't obvious for me, that crash occurred due to missing this file). I just wondering if I miss somewhere the instruction for nmake.exe to generate this makefile?

    In src.pro in parent directory for Qt\qtbase\src\angle\src I see next

    TEMPLATE = subdirs
    SUBDIRS += compiler libGLESv2 libEGL
    CONFIG += ordered
    

    Makefile is generated for compiler directory, but in libGLESv2 libEGL makefiles are missing, probably that could explain what I am missing....


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.