Important: Please read the Qt Code of Conduct -

toolchain.prf(50): system(execute) requires one or two arguments.

  • Hello.
    I has migrated my project (arm11, linaro4.7 cross-compiling) from Qt5.4.2 to Qt5.9.1 and catch some error.
    When I choose debug build I have next error messages in QtCreator 4.0.2:
    /usr/local/qt/qt591-chipsee-egl/mkspecs/features/toolchain.prf(50): system(execute) requires one or two arguments.
    Project ERROR: Cannot run compiler '/home/user/work/tools/linaro-4.7/bin/arm-linux-gnueabihf-g++'. Maybe you forgot to setup the environment?
    Error while parsing file /home/user/work/_projects/eWSH/ Giving up.
    Pro file is not parsed, project is not displaying in QtCreator.

    In release mode these errors are not occured.
    Also in spite error messages compilation is successful even in debug mode.

    I see next lines in toolchain.prf file:

            output = $$system("$$cmd_prefix $$QMAKE_CXX $$qtMakeExpand($$cxx_flags) -xc++ - 2>&1 $$cmd_suffix", lines, ec)
        ret = $$system("$$1 -E $$system_quote($$PWD/data/macros.cpp) <$$null_device 2>$$null_device", lines, ec)
        !equals(ec, 0): \
            error("Cannot run compiler '$$1'. Maybe you forgot to setup the environment?")

    I tried to remove "lines" parameter. Error message was suppressed, but project still not displaying in QtCreator.

    Can somebody point me to syntax of prf file of help with parameters system() function?


  • @titan83 And I answer myself to question above.
    In file mkspecs/features/default_pre.prf I commented last line "load(toolchain)"

  • thanks a lot!!!

  • @titan83 - usualy it's when you've configured your compiler path to gcc instead of g++. You can try to check that and uncomment (get back) your line at the end of default_pre.prf file.
    I wonder if it help?

Log in to reply