Unable to locate ICU library icuin51.dll



  • So I made an IDE but then realized that I need to have it working on WinXP instead of 10 (which I'm developing it on) so I went down from QT 5.8 to QT 5.2.0 MinGW

    When I'm deploying the app using windeployqt.exe, it says the exact thing I have in the title. Do I have to add its path to env variables to make it work?



  • Hi, about Qt apps for Windows XP, I'm also facing the same problem, but I didn't go back as far as 5.2.0, I've used Qt 5.7.1 (that's the very last version that works fine on XP).

    Re. icuin51.dll, if windeployqt throws a fit, you can just manually copy the 3 icu*.dlls to to your deployment directory (place them next to your .exe).



  • @hskoglund Ok that helped

    As for the deployment on a different pc, Do I need to install the MinGW package supplied by QT, or is there a way to use the MinGW installer to get the needed dependancies?
    I tried installing MinGW on a pc without having QT on it, but its complaining about libwinthread-1.dll missing.

    I never had that issue when I used 5.8 VC and everything worked after I installed vcredist.exe.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.