QVTKWidget Error!! Please Help



  • Hello All,

    I got the VTK 5.6.1 successfully installed on opensolaris along with the QVTK widget. Also when I tried to run the Qt project which uses QVTKWidget on Linux(UBUNTU) it was successful and i could see the output. When I try to run the same code(with required changes made for the solaris system)
    I m getting the following error.

    Undefined first referenced
    symbol in file
    vtkAlgorithmOutputvtkAlgorithm::GetOutputPort(int) mainwindow.o (symbol belongs to implicit dependency /usr/local/lib/vtk-5.6/libvtkFiltering.so.5.6)
    vtkPNGReader
    vtkPNGReader::New() mainwindow.o (symbol belongs to implicit dependency /usr/local/lib/vtk-5.6/libvtkIO.so.5.6)
    vtkImageViewervtkImageViewer::New() mainwindow.o (symbol belongs to implicit dependency /usr/local/lib/vtk-5.6/libvtkRendering.so.5.6)
    void vtkImageViewer::SetupInteractor(vtkRenderWindowInteractor
    ) mainwindow.o (symbol belongs to implicit dependency /usr/local/lib/vtk-5.6/libvtkRendering.so.5.6)
    ld: fatal: symbol referencing errors. No output -----written to vtk
    make: *** [vtk] Error 1

    Please help me with the changes that i have to make.
    Awaiting your reply.



  • I had to link the other libraries as well. I got it built. But when I run the application file It says segmentation fault(Core Dumped) . But I don see anything wrong with the pointers or anything that I have used.
    Also when I include the (LIBS += -L/usr/local/lib/vtk-5.6 -lQVTK -lvtkRendering -lvtkIO -lvtkFiltering) .... in the .pro file I have this problem. Though I am not using any of its classes(QVTKWidget etc..,) But if I comment that line it works fine.

    Its a run time error and is related to the Shared Libraries.

    I have also set the LD_LIBRARY_PATH!!!

    What Might have gone wrong.

    I am totally stuck, Please Hel



  • Hello folks,

    i don't if the problem is sovled right now but i have the same Problem using QVTKWidget with QT!
    I'm using QTCreator Version 4.8.0 an VTK version 5.8.
    So i created a small an simple Application under WIN7 x64 and put in the *.pro file the INCLUDEPATH of VTK (INCLUDEPATH += "C:\VTK5.8.0\include\vtk-5.8") and all LIBS of the vtk which are in the folder "C:\VTK5.8.0\lib".
    I build it successfully!
    After that i added a Widget in my application and promoted that to QVTKWidget. But now when i would like to build the hole program i get a error that i don't know what to do with that.

    This is it:
    _mainwindow.obj:-1: error: LNK2019: unresolved external symbol "public: __thiscall QVTKWidget::QVTKWidget(class QWidget *,class QFlags<enum Qt::WindowType>)" (??0QVTKWidget@@QAE@PAVQWidget@@V?$QFlags@W4WindowType@Qt@@@@@Z) referenced in function "public: void _thiscall Ui_MainWindow::setupUi(class QMainWindow *)" (?setupUi@Ui_MainWindow@@QAEXPAVQMainWindow@@@Z)

    Can anyone please help me with that error? Any suggestions will be great!
    Thx!
    Mario


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.