Building Qt source code for [Qt4.7.3 for Symbian^3] target and got a bug about bass_patched_caps.dll



  • Hi All!
    I built my application for [Harmattan 1.2 API] and when I build that source code for [Qt4.7.3 for Symbian^3]<smart installer> target I get this error.

    :-1: error: C:\QtSDK\Symbian\SDKs\Symbian3Qt473\epoc32\data\z\sys\bin\bass_patched_caps.dll is not a valid E32Image file.

    My pro file like this
    @

    Add more folders to ship with the application, here

    folder_01.source = qml/nokiaqt
    folder_01.target = qml
    DEPLOYMENTFOLDERS = folder_01
    folder_02.source = ../../bin
    folder_02.target = res
    DEPLOYMENTFOLDERS += folder_02

    Additional import path used to resolve QML modules in Creator's code model

    QML_IMPORT_PATH =
    QT+=opengl
    QT+= phonon
    LIBS += -lQtOpenGL
    CONFIG += console
    RESOURCES = res.qrc
    symbian:TARGET.UID3 = 0xE0ED2485
    DEFINES += QT_CREATOR=1

    Smart Installer package's UID

    This UID is from the protected range and therefore the package will

    fail to install if self-signed. By default qmake uses the unprotected

    range value if unprotected UID is defined for the application and

    0x2002CCCF value if protected UID is given to the application

    #symbian:DEPLOYMENT.installer_header = 0x2002CCCF

    Allow network access on Symbian

    symbian:TARGET.CAPABILITY += NetworkServices

    If your application uses the Qt Mobility libraries, uncomment the following

    lines and add the respective components to the MOBILITY variable.

    CONFIG += mobility

    MOBILITY +=

    The .cpp file which was generated for your project. Feel free to hack it.

    SOURCES += main.cpp
    ......

    Please do not modify the following two lines. Required for deployment.

    include(qmlapplicationviewer/qmlapplicationviewer.pri)
    qtcAddDeployment()

    OTHER_FILES +=
    .................
    @

    Did I config some things wrong?

    After building for [Qt4.7.3 for Symbian^3] target with some bug above, i got a installer.sis file, I installed it on X7 but it coun't finished.



  • i have the same problem but with the qt3d


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.