Problem with code::blocks;Qt4;MingW;The procedure entry point.. could not be located in the dynamic link library QtCore.dll:



  • I am running Code::Blocks 10.05 with the MingW compiler package on a Win7-32 box.

    I downloaded and installed the Qt libs for Windows/MingW (qt-win-opensource-4.7.3-mingw.exe) - installation went smoothly - BUT when it prompted me for the directory for MingW and I pointed it to Code::Blocks installation directory, Qt installer told me my Qt package was for MingW 4.4 and I had 4.4.1 installed - 'installation may not work'. I installed anyhow, figuring there's no significant difference between 4.4 and 4.4.1 and the installation finished without error, all the Qt libs and tools are installed.

    Afterwards, in Code::Blocks I created a small test project using the Code::Blocks wizard - here is the code:

    #include <QApplication>

    int main(int argc, char* argv[])

    {
    QApplication app(argc, argv);
    return app.exec();
    }

    The code built fine in the IDE - no errors or warnings, but when I ran it, I immediately received this error message, and the app exited with an error code:

    "The procedure entry point _ZI3qFlagLocationPKc could not be located
    in the dynamic link library QtCore.dll"

    Anybody know what's going on here? Is it because of the MingW version discrepancy I was warned on, or some other reason? How can I fix this? I want to use Qt Code::blocks, not Nokia QtCreator.

    TIA



  • How did you run it? Did you pressed the green "play" button within Qt Creator?



  • Do you have your Qt libs in your PATH?



  • [quote author="loladiro" date="1312451221"]Do you have your Qt libs in your PATH?[/quote]

    Also: do you have the CORRECT Qt libs in your PATH? Notice that (as far as I understand), at least with Windows, there is one set of these libs for internal use by Qt Creator ("4.7.4" version) and another set to be linked with your applications (4.7.3 version). ;-)



  • I found with 4.8 that this will happen if you copy the wrong DLLs for the target. For me it was that I needed those from the ...*Desktop*\Qt\4.8.0\mingw\bin ... Any DLL from another target would produce that same error.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.