Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Cross Compile Ubuntu 16.04 and BBB running Debian 8.8 w/ Touchscreen



  • Hello,
    I am new to Qt and the BeagleBone and have been trying to get Qt 5.9 to work on the BBB for a while now and keep running into issues (libraries not being found or cannot find platform plugins). I have been able to get Qt 4.8 to work with tslib, but have been trying to get an updated version.

    System Information:
    Windows 10 running a VM of Ubuntu 16.04.2 LTS
    BeagleBone Black running Debian 8.8 with a 4D cape 7” Touchscreen
    arm-linux-gnueabihf-gcc (Debian 4.9.2-10) 4.9.2

    I started following the tutorial here: https://wiki.qt.io/BeagleBone_Black_Beginners_Guide

    The link for step 4 (the cross compile tools) is dead so I have tried:
    https://github.com/plexydesk/cross-compile-tools.git
    and
    wget https://raw.githubusercontent.com/ri...lativelinks.py
    ./sysroot-relativelinks.py /mnt/bbb-rootfs
    (from https://wiki.qt.io/RaspberryPi2EGLFS )
    I’m not sure if either of these are even the correct tools needed anymore.

    I have tried the toolchains:
    gcc-linaro-4.9-2015.05-x86_64_arm-linux-gnueabihf
    gcc-linaro-4.9-2016.02-x86_64_arm-linux-gnueabihf

    After reading this post here I even tried:
    gcc-linaro-6.2.1-2016.11-x86_64_arm-linux-gnueabihf
    sysroot-glibc-linaro-2.23-2016.11-arm-linux-gnueabihf

    I downloaded all of Qt 5.9 including sources using the online installer: qt-unified-linux-x64-3.0.0-online.run

    The configure I’m using is:
    ~/Qt/5.9/Src/qtbase/configure -release -shared -device linux-beagleboard-g++ -device-option CROSS_COMPILE=~/opt/gcc-linaro-4.9-2016.02-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/bbb-rootfs -opensource -confirm-license -make libs -prefix /usr/local/Qt-5.9 -extprefix /mnt/bbb-rootfs/usr/local/Qt-5.9 -hostprefix /usr/local/Qt-5.9 -nomake examples -qt-zlib -qt-libpng -no-opengl -no-icu -v

    I have also tried with the flag -no-eglfs or getting rid of the -no-icu and either way I still get different types of errors at either build or run depending on which arguments I used in configure. The most recent error using the configure above gave me:
    This application failed to start because it could not find or load the Qt platform plugin "eglfs"
    in "".
    Available platform plugins are: linuxfb, minimal, offscreen, vnc.
    Reinstalling the application may fix this problem.
    Process killed by signal

    What am I missing to be able to get Qt to work on the BBB with the touchscreen?
    I appreciate any help!


  • Qt Champions 2019

    @dmccann said in Cross Compile Ubuntu 16.04 and BBB running Debian 8.8 w/ Touchscreen:

    The most recent error using the configure above gave me:
    This application failed to start because it could not find or load the Qt platform plugin "eglfs"
    in "".

    To me it is not clear: did you build Qt successfully? Can you show the output of configure?


Log in to reply