Custom run environment for manual added kit added to Qt Creator



  • We have a custom build of Qt that uses different versions of zlib and icu than what Creator uses. When we add the paths of the 2 libraries to the PATH environment for the kit, Creator crashes when loading our projects using that kit.

    Adding path to the LIB variable seems OK.

    I can add the path to the run environment of the project but then we need to add it to every single project using it.

    Is there a way to set different environments for build and run in the kit?


  • Qt Champions 2016

    Why not just compile Creator with your version (if possible) ?



  • Qt Creator is not part of our toolchain. We only use it to verify small issues and make reproduction samples for Qt support. I'd rather not spend more time on the tools than our own products. Plus, this shouldn't happen. The environment should apply to the build and run, not Creator itself.

    And it turns out we need the PATH set to include the icu and zlib we use since Qt tools like rcc needs them.

    I am able to set both LIB and PATH in the kit environment when I disable all QtQuick plugins. It seems one or more of the plugins are loading the libraries from the PATH instead of wherever Creator has them.



  • BTW. This is on Windows and Creator 4.3 Enterprise.


  • Qt Champions 2016

    Ok, if you do not need QtQuick it sounds like a workable solution.
    I would post to the mailing list and ask the devs directly just in case nothing else
    turn up here.

    Just as a note, its possible to use cmdline tool like xmlstarlet
    to make it very easy to add a set of predefined settings to the .user file so the burden of
    setting up a new project can be quite small.



  • Please report bugs to bugreports.qt.io! We actually fix bugs reported there, while you need to be very lucky to get your report noticed here.

    This one should be fixed in the upcoming 4.3.1 release.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.