Error 0xc00007b with sdktool.exe and qtcreator.exe on Windows.



  • After installing Visual Studio 2017 i deciced to update Qt so that it can work with windows 2017 compiler. During the installation error 0xc00007b kept appering. I tried to go through it and ignored the warnings, so that the installation can complete. Once completed I tried to launch it but the error 0xc00007b showed up. Next I tried to open the old one but got the same error. Any idea how to fix it?

    I tried:

    • run as administrator
    • compatibility mode for everything from XP SP1 to 8.1
    • a lot of installing anew
    • reinstalled .Net and DirectX
    • updating to newer version of Windows
    • CCleaner


  • Hi, I'm guessing that error occurs because you have a previous Qt installation for a 32-bit Visual Studio version and you tried to install a 64-bit version (the error 0xc000007b means there's a mixup of 32-bit and 64-bit versions of the same dll in your path). You could try uninstalling previous versions of Qt first.



  • Forgot to mention it but that was one of the first steps which I have done. But I made sure I installed everything in 64-bit version. One thing that I have forgotten to add was that after finishing the VS 2017 installation VS 2015 stopped working with the same error code (0xc000007b). Also I have noticed that for some reason I have duplicite Microsoft Visual C++ Redistributable 2008 and in path I have duplicite (written two times) "C:\Windows", "C:\Windows\system32", "C:\Windows\system32\wbem" and "C:\Windows\system32\WindowsPowerShell\v1.0".



  • Hmm so VS2017 and VS2015 are fighting with each other? Then one of them has to be uninstalled I think, to get rid of 0xc000007b.



  • Uninstalled VS 2015 even before posting this.



  • Well there's some DLL in there that causing 0xc00007b. You can try downloading Dependency Walker, unpack the zip and start the program. Then open qtcreator.exe in it, hit F7 and Ok. Qtcreator.exe will load with a trace in Dependency Walker, it should what DLL is the culprit.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.