Creator git plugin



  • Hey guys,

    I have some problem with the git plugin of the Qt Creator.
    Every time I try to create e new projekt from git repositorie, nothing happens.

    I wait minutes but nothing no error messages or something.

    When I try to push to an online repo I get a time out error.

    Is there anybody who uses the git plugin under windows or has anybody an idea what could be the problem ?
    Are there any requirements for using the git plugin ?

    I read in the version control menu that perl is required so I installed active perl is this the right one or do I have
    to install another perl ?

    I also installed git itself for sure.



  • I've used it without issues. Which platform and which version of software are you using? Is there a firewall blocking your network?


  • Moderators

    Works-for-me(TM)

    Which protocol are you using to push/pull? Can you log into your git server using SSH or HTTP? Does git work from the command line?



  • Hi,

    ok I have a Firewall on my system maybe I should check this ^^

    I work on a Win7 OS with the 2.0.8 version of the QtCreator, I installed git in version 1.7.1

    It seems that the Creator generates the .git directory but can't reach the github repository.

    @ Tobias

    I have my repos on github and I tried it with ssh "git@github.com:Mylogin/Myrepo.git".

    Normally I use the gui that comes with git to push and pull and that kind of stuff.
    This works fine with GUI and CLI. But I wanna use git directly in the Creator.

    I first going to check my firewall when I come home.
    If this isn't working I try to clone via HTTP I guess I didn't tried this already.

    Thanks guy if you have some advices for me please let me know ; )


  • Moderators

    Did you set up git in Tools->Options->Version Control->Git? You need to set a path (just click on "From System" and prepend "C:\Program Files (x86)\Git\bin;" and I had to check the "set HOME" option for git to pick up my SSH keys.

    I have a pretty similar setup (using msysgit). Msysgit ships with its own perl included.



  • The path to git was automatically set. If I click "From System" i get some weird path strings.

    The thing is that the Creator already works with git, i can view the history, comments and all that stuff even committing is possible.

    What isn't working is push/pull and these things. So I guess that my firewall should be the problem.

    I leave you a comment if this is the reason.



  • Hm no it doesn't seem to be the firewall which blocks any communication.

    It just don't work.

    When I want to create a new project from git repository the Creator builds the directory with the
    .git subdir but there are no files from the repository.

    Any other ideas ?



  • [quote author="Schneidi" date="1283944747"]
    If this isn't working I try to clone via HTTP I guess I didn't tried this already[/quote]

    did you try with http? i have similar issue with git and so use http, which works fine. For me its the firewall that blocks :(



  • Yes I tried to pull with http, it was the same thing.

    The Creator started to build the directory but didn't get any data from the server.
    I also turned off my firewall, but there were no changes.

    I don't understand whats wrong here.

    I took a look at the tasks and saw that there were the ssh and git processes without doing anything and that for hours.



  • ok have you tried to download some other repository from git? how about using http and trying to get the qt sources itself? for me within minutes a few MB is downloaded ...

    url: "http://git.gitorious.org/qt/qt.git":http://git.gitorious.org/qt/qt.git



  • No I didn't try other repos but I will check some other sources.

    I will try this for example.



  • Nope there is no way in.

    I tried to clone qt via http but all I got is a process "git -remote-http.exe" which utilize the cpu at full capacitiy. The firewall of off and I don't know what this process is doing anyway.



  • This is best diagnosed by trying to run 'git pull' from the command line (cmd.exe, emulating Qt Creator calling).
    A common pitfall in an installation with msysGit 1.7.X configured with 'git bash' only is that git relies on the environment variable HOME being set in order to locate the SSH key files.
    bash does that, but for cmd.exe and Qt Creator executing git, it is not set and git then defaults to its installation directory to find the keys.
    As a workaround, HOME can be set to %HOMEDRIVE%/%HOMEPATH% in the Windows environment. Qt Creator 2.1 will contain a setting to optionally do this when running git.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.