[solved] Qt on Solaris10



  • Can someone provide me a link or a detailed explanation of installation procedure of Qt Creator and other libraries(if required) on Solaris system. And also the links from where I can download all the required files.

    Thank You.



  • I downloaded qt-x11-opensource-src-4.4.3.tar.gz2

    untared it and then ran the configure file using : ./configure -platform solaris-g++

    then ran 'gmake'

    it build for a long time but finally ended up with the following error msg:

    In file included from ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardAnalyzer.h:18,
    from ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardAnalyzer.cpp:8:
    ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardFilter.h:16:40: StandardTokenizerConstants.h: No such file or directory
    In file included from ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardAnalyzer.h:19,
    from ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardAnalyzer.cpp:8:
    ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardTokenizer.h:52: error: TokenTypes' has not been declared ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardTokenizer.h:52: error: ISO C++ forbids declaration oftokenCode' with no type
    ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardTokenizer.h:54: error: TokenTypes' has not been declared ../../../../src/3rdparty/clucene/src/CLucene/analysis/standard/StandardTokenizer.h:54: error: ISO C++ forbids declaration offorcedType' with no type
    gmake[3]: *** [.obj/release-shared/StandardAnalyzer.o] Error 1
    gmake[3]: Leaving directory /home/ing03874/qt-x11-opensource-src-4.4.3/tools/assistant/lib/fulltextsearch' gmake[2]: *** [sub-lib-fulltextsearch-make_default-ordered] Error 2 gmake[2]: Leaving directory/home/ing03874/qt-x11-opensource-src-4.4.3/tools/assistant'
    gmake[1]: *** [sub-assistant-make_default-ordered] Error 2
    gmake[1]: Leaving directory `/home/ing03874/qt-x11-opensource-src-4.4.3/tools'
    gmake: *** [sub-tools-make_default-ordered] Error 2

    PLEASE HELP

    Thank you.



  • How about trying with a recent Qt first? Which toolchain are you using? Remember also to disable webkit / javascriptcore.



  • how do i disable them? whats tool chain? sorry, i m beginner.

    Also,
    What is the error that I m getting(the one tht is mentioned above)?? How can I fix it?? . My solaris version is SunOS 5.10

    Thank you.



  • I am referring to this :
    http://code.google.com/p/tonatiuh/wiki/InstallingQtForOpenSolaris

    At the configuring stage I get this error: Basic XLib functionality test failed!
    You might need to modify the include and library search paths by editing
    QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /export/home/sol/qt-everywhere-opensource-src-4.6.2/mkspecs/solaris-cc-stlport.

    How can I fix this problem.

    Please help.

    Thank you.



  • Seems like configure script can't found your X11 libs and headers (may be you forgot install devel package for X11?) try find paths to them manually and edit file /export/home/sol/qt-everywhere-opensource-src-4.6.2/mkspecs/solaris-cc-stlport with found paths



  • I am working on OpenSolaris. There is X11 installed on my system. I tried editing the 'solaris-cc-stlport' file, (where I added the path to Xlib.h and X11.so)
    But still I m having the same problem.



  • Hi..,

    I got Qt installed successfully(though I did not get any mgs , I assumed its installed)
    The error was giving the right path in the solaris-cc-stlport' file.

    But now how do I run the examples?

    Please help.

    Thanks!!



  • if you build Qt with this configure line

    bq.
    ./configure -platform solaris-cc-stlport -webkit -nomake demos -nomake examples

    examples didn't build with it. you can try build some examples manually.
    Just open example dir and try

    bq.
    qmake
    make



  • I got it running.. Thank you..!!


  • Moderators

    If you've got it working, please be kind and add [Solved] to the title of the original post. Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.