Help on buildind to Windows 10



  • Hi, guys.

    I'm i developer from a company that is actually porting some codes from actionscript and java to C++, and we recently have choosen Qt.

    I've already installed Qt Creator at some machines: in Mac and Windows 7 it´s working ok, very nice. But in some Windows 10 machines, even with fresh OS install, I can´t neither run the simplest console application:

    #include <QCoreApplication>

    int main(int argc, char *argv[])
    {
    QCoreApplication a(argc, argv);
    return a.exec();
    }

    This error always happens:

    Starting C:\Users\carlo\OneDrive\Documentos\build-untitled2-Desktop_Qt_5_9_0_MinGW_32bit-Debug\debug\untitled2.exe...
    The program has unexpectedly finished.
    C:\Users\carlo\OneDrive\Documentos\build-untitled2-Desktop_Qt_5_9_0_MinGW_32bit-Debug\debug\untitled2.exe crashed.

    I llok at some forums, and many people thinks that it seems to be caused by an abscence of some dll file.

    Well, I'd appreciate it for some help.

    Thanks a lot.



  • Hi, just a quick guess, but try placing your program somewhere else than in the OneDrive folder.



  • Thanks for the reply.

    At this machine, i'm using the OneDrive folder.

    But the same occurs at other installations at 2 other Windows 10 PCs. In both cases, the projects are located at "normal" folders.



  • Ok another quick guess: have you tried building in Release instead of Debug?



  • I´ve just tried Released and the machine crashed (freezed).

    I tried at other machine, the same code.

    The console window doens´t present the QCoreApplication standard message. Nothing happens. Both release and debug.

    When a close console, it returns this error:

    C:\Users\cranoya\Documents\build-untitled2-Desktop_Qt_5_9_0_MinGW_32bit-Release\release\untitled2.exe exited with code -1073741510



  • I've tried again at the crashed PC and release built worked.

    The console window shows the message "Press <RETURN> to close this window..."

    But debugg built still not works....



  • Are you trying just to run the app you created, or are you trying to develop on all those machines?
    If going for just running it, have you gone thru the windeployqt command?



  • Hi Xyrer.

    I'm just trying a very simple thing: I install Qt Creator, crete a new project (console application), press the "build and run" button, and this happens. I did it many times (including reinstalling Qt) and the same happens in two of my PCs.

    With my Windows 7 PC at home i'm working fine (i'm working with Qt just now). With my parter's Mac it's ok too.

    I don't know if it's a coincidence, by these two Windows 10 PCs are giving the this headache...

    Thanks for replying.


  • Moderators

    @carlos-ranoya said in Help on buildind to Windows 10:
    I install Qt Creator, crete a new project (console application), press the "build and run" button, and this happens.

    What do you see if you click "Start Debugging" instead of "Build and Run" (using a Debug build)?

    Also, which version of Qt did you install on each PC? Are they all Qt 5.9.0 for MinGW 32-bit?


Log in to reply