Problem with execute exe file on Windows XP



  • Hi. I have problem with execute my qt exe on windows xp. when i try I get Exceptin Processing Message c0000139 Parameters 18ee68 169428 75b4bf7c 75b4b7c error... I m really bad.
    it works on windows 10, 7, 8 but xp is a problem.

    Anyone can help me???

    Im using QT5.6.2 with Mingw.

    My .pro file is

    #-------------------------------------------------
    #
    # Project created by QtCreator 2017-03-01T21:14:27
    #
    #-------------------------------------------------
    
    
    
    
    
    win32 {
        contains(QMAKE_TARGET.arch, x86_64) {
            QMAKE_LFLAGS_WINDOWS = /SUBSYSTEM:WINDOWS,5.02
            QMAKE_LFLAGS_CONSOLE = /SUBSYSTEM:CONSOLE,5.02
        } else {
            QMAKE_LFLAGS_WINDOWS = /SUBSYSTEM:WINDOWS,5.01
            QMAKE_LFLAGS_CONSOLE = /SUBSYSTEM:CONSOLE,5.01
        }
    }
    
    DEFINES += _ATL_XP_TARGETING
    
    
    DEFINES += PSAPI_VERSION=1
    
    INCLUDEPATH += “ //kckr/Department/Boyahane/Teknik/Enerji_Arıtma/Ufuk/komur”
    
    
    QT       +=  core gui sql
    greaterThan(QT_MAJOR_VERSION, 4) {
        QT *= printsupport
    }
    
    
    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
    
    TARGET = komur
    TEMPLATE = app
    
    # The following define makes your compiler emit warnings if you use
    # any feature of Qt which as been marked as deprecated (the exact warnings
    # depend on your compiler). Please consult the documentation of the
    # deprecated API in order to know how to port your code away from it.
    
    
    # You can also make your code fail to compile if you use deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x050000    # disables all the APIs deprecated before Qt 6.0.0
    
    
    SOURCES += main.cpp\
            login.cpp \
        anasayfa.cpp \
        veri.cpp \
        veritopla.cpp \
        edit.cpp \
        yonetici.cpp \
        yoneticiveri.cpp \
        komurkirec.cpp \
        verivv.cpp
    
    HEADERS  += login.h \
        anasayfa.h \
        veri.h \
        veritopla.h \
        edit.h \
        yonetici.h \
        yoneticiveri.h \
        komurkirec.h \
        verivv.h
    
    FORMS    += login.ui \
        anasayfa.ui \
        veritopla.ui \
        edit.ui \
        yonetici.ui \
        yoneticiveri.ui \
        komurkirec.ui \
        veri.ui \
        verivv.ui
    
    DISTFILES +=


  • Can anyone help for this problem. What can i do.? If this problem cant work in xp i m thinking sucide :(



  • Hi!

    Did you have this code in your project pro file for Win XP compatibility?

    win32 {
        contains(QMAKE_TARGET.arch, x86_64) {
            QMAKE_LFLAGS_WINDOWS = /SUBSYSTEM:WINDOWS,5.02
            QMAKE_LFLAGS_CONSOLE = /SUBSYSTEM:CONSOLE,5.02
        } else {
            QMAKE_LFLAGS_WINDOWS = /SUBSYSTEM:WINDOWS,5.01
            QMAKE_LFLAGS_CONSOLE = /SUBSYSTEM:CONSOLE,5.01
        }
    }
    
    DEFINES += _ATL_XP_TARGETING
    


  • @Cobra91151 thank u for your answer. After your reply i set tihs to my pro file. but same error is happen :(



  • @atraks

    What architecture is your app (x86 or x64)? If you can make screenshot of this error then post it here.



  • @Cobra91151 https://ibb.co/eokzwF
    error is that

    @Cobra91151 https://ibb.co/fOpgAa
    is my compile screen.

    I compile this program on x64 windows 10 system but deploying x86 programs thank u your answers :(



  • @atraks

    If your problem is solved please mark it as solved.



  • @Cobra91151

    no, same error is happen. :( can u see my images?



  • @atraks

    No. Try to upload to ImgBB host.



  • @Cobra91151 i changed the uploader. Please help me

    now i rebuild it again and get error subsystem:windows,5.01: no such file or directory foulth from my compiler.



  • You didn't mention the version of Qt that you are using (or any other details for that matter). I believe Qt 5.6.x is the latest that you can use for XP.

    I would recommend compiling your program on WinXP and then you will know it works on this target. You can setup a virtual machine with XP and a minimal set of what you need to compile software. This is basically what I have setup as I need to make sure my software runs on this older operating system.

    My guess is that you are using a version of Qt that no longer supports XP (for example, I don't think Qt 5.8.x supports XP anymore). You might have a problem with your version of Qt were it was not compiled with the proper options to support XP. Either way the best way to solve this is to setup an environment on WinXP and compile your program there. If it works on XP it will run on Win10 but the reverse is not always true.



  • @Rondog thank u for your answer

    I m using Desktop QT 5.6.2 mİNGW 32 bit, I guess it is competible with windows xp.

    I try to setup online qt-unfied-windows-x86-2.0.5.1-online. exe file from qt site to my xp system.. But Iı get not valid win32 application error.
    i dont know what is my problem.



  • I am also developing my apps for Win XP and use Qt 5.7.1, everything works from Win XP to Win 10, but I use Visual Studio compiler. I think the problem might be with MinGW or wrong library distribution. Try to run clean and qmake then build your project. Use Qt Command Prompt with command: windeployqt NameOfYourApp.exe to distribute your project libraries (don't forget to set path to your executable dir). Then try it on Win XP.



  • @Cobra91151 i run clean and qmake, get error subsystem:windows,5.01: no such file or director..

    I guess Mingw is a problem. can ı set my code visual studio? Is it hard?



  • You can try Visual Studio compiler.

    1. Save your project and close Qt.
    2. Download and install free MS Visual Studio 2015 Community version
    3. Try to build your project.

    Make sure you have auto selected Visual Studio kit in Qt or you will have to select it manually.



  • @Cobra91151 i wll try, u mean qt 5.6.2 with vs2015 can ı succed it?

    thank u my hero



  • @atraks

    I think it will support it. Check this link for compatibility Qt Supported Platforms and Configurations

    By the way, when compiling app with Qt 5.7.1 will also support Win XP SP3 x86 (even I have tried on Win XP SP2 x64) but in docs it has no support.



  • can anyone suggust something?



  • @atraks I am using Qt 5.6.0 with Mingw32 and it works fine from XP to Win10.

    I suspect the difference is that I build my version of Qt from source. I also compiled my version of Qt on WinXP just to make sure it works on this OS. I don't use WinXP to write any software but I do use this to compile programs that are required to run on Windows.

    Your version of Qt needs the compile options "-target xp -no-directwrite". Example:

    ./configure -target xp -no-directwrite ...
    

    If your version doesn't have these configure options set when compiled it won't work on WinXP (I believe, I didn't try it personally).

    I also found I had to change one of the configure executables so it would run on WinXP (it has a target version set higher than WinXP). This situation returns the 'Not a valid Win32 Application' error (that was mentioned in this thread).

    You could also use older versions of Qt I suppose. You might run into new problems if you do this though if you want to compile on Win10. An older version of Qt on an older operating system like Win7 (WinXP preferred) should produce something that can run on WinXP.



  • Hi, just to add to @Rondog I also use Qt 5.6.2 with MinGW, compiling on Windows 10 64-bit and deploying on Windows XP SP3 32-bit. To get my programs to run on Windows XP I don't need to do recompile or rebuild Qt, I just download the standard Qt 5.6.2 MinGW 32-bit Qt flavor.

    About your error: QMAKE_LFLAGS_WINDOWS setting does not work with MinGW compiler. But it is also not needed for the MinGW compiler. when you compile with MinGW compiler you can start your .exe file on Windows NT 4, Windows 2000 and Windows XP.

    I'm guessing that error message "Exception processing message 0xC0000139..." instead comes from some problem with your antivirus program and drive letters, try ejecting all USB disks and memory cards from your computer so that only your C: hard disk is connected (note: this is just a guess!).



  • @Rondog THANK U for your answer.

    Where is the compile options for no direct write? you mean in profile write ""./configure -target xp -no-directwrite ...""? I search everything in QT and i didn't find this option. I m really noob sorry about that. Can u help me? I try low versions of qt but when i try to start setup exe which is for QT, i get win32 error. Which configure exetables u change... Thank u for your interest..



  • i was working on a OpenGL project using Qt 5.7.0 and Visual Studio. Works fine under Windows XP BUT i needed to set Plattformtoolset to Visual Studio 2015 - Windows XP (v140_xp)

    So maybe there is something similar for Qt??

    btw @Rondog i compiled Qt for my Visual Studio version from the source and i did not use -target xp -no-directwrite. So if it is not a default setting (and target xp is no default) it's not needed.



  • @hskoglund i try to open this exe files on my company pcs and i get c000139 error too... :( i think problem is my exe file. can ı sent u my file, can u try it?



  • @atraks

    You can upload here your app and I will test it on virtual machines.

    Also I can upload here a test project that will run on all Windows editions (compiled on Visual Studio compiler with Qt 5.7.1), so you can try?



  • @Cobra91151 im on work now, and this computers block uploading. Please send me your file to try. I ll sent my file at 19.30 pm. thank u!!!!!!!!!!! im really exited about that!



  • @Cobra91151 my file is http://www.filedropper.com/kom komur.exe is my main exe file.



  • @atraks

    Hi! When launching komur.exe it throws error on Win XP:

    alt text

    Also I have noticed a lot of unnecessary files which takes about 500 MB.

    I think:

    • You need to delete/clean your project folder and build project again.
    • To deploy it you should use Qt Command Prompt, navigate to your project executable directory with command cd and proceed with command: windeployqt komur.exe (this will add all necessary files/libraries).
    • Upload your project again so I can test it.

    I have some issues with test project, so I will upload it as soon as I fix them.



  • @Cobra91151 @hskoglund @Rondog thank u very much...... I love u guys!!!!!!!!!!!!!!!!!!!!!!!!!!!! i succeed it.
    i solved my problem with setup QT to my xp machine. I notice that my errors come from my windows 10 QT dll files.... exp (QWidger.dll, lib-2.dll.. eg.) When i use windows xp QT dll files my problem is gone...
    If someone has a problem like that have to get these dll's from somewhere. Don't use other os's QT files.Just find these dll files...



  • @atraks

    Hi! Even though you have fixed your issue. Here is my test project - Mega (compiled on Visual Studio 2015 compiler with Qt 5.7.1 that will work from Win XP to Win 10).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.