32-bit libraries on Mac OS X 10.6 missing from install?



  • Forgive me if this is a stupid question.

    Why is QtCore.framework 64 bit only on Mac OS X?
    @[lib/QtCore.framework]% file QtCore
    QtCore: Mach-O 64-bit dynamically linked shared library x86_64@

    I tried building a simple 32bit C++ library and wanted to use some Qt libraries and I always get the error:
    @Undefined symbols for architecture i386:
    "QString::fromAscii_helper(char const*, int)", referenced from:
    QString::QString(char const*)in cciLB4my.o
    "QString::free(QString::Data*)", referenced from:
    QString::~QString()in cciLB4my.o
    "QLibrary::QLibrary(QString const&, QObject*)", referenced from:
    _main in cciLB4my.o
    "QLibrary::load()", referenced from:
    _main in cciLB4my.o
    "QLibrary::~QLibrary()", referenced from:
    _main in cciLB4my.o
    ld: symbol(s) not found for architecture i386
    collect2: ld returned 1 exit status@

    Now I came across another post in this forum which mentions that I have to build the 32-bit Libraries on Mac OS X myself.
    Is this true?

    Can I just build the libs, because I don't want yet another installation of Qt. (I installed 4.7.3 from the website using the Online-installer)
    Can I just put them beside my existing libs? (At the moment my Qt installation is under ~/Dev/Qt/... can I just put them in a parallel directory to the libs in the current installation e.g. "lib32") Or better said how would it be most practical since I am using Qt Creator and I then would like to build 32-bit only.

    Sorry for asking such basic questions but I never worked with Qt Creator or even Qt before.

    If someone could share a little insight I would be very happy.

    Thomas Krajacic


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.