[solved] Window stays blank after deploying application to another Windows-PC



  • We've had all this a lot of times. Normally I was able to figure out myself what was going wrong, but this time I have no clue why my window stays blank on another PC.

    I hit up the almighty process monitor to see what was going wrong and fixed most stuff (like missing Qt.conf-file). Now the only thing which could be wrong are the following files. What could be the problem?

    !http://img35.imageshack.us/img35/7760/missingqmldir.png(screenshot of missing files)!

    Both QtDeclarative and QtDesktop (styleplugin.dll) are included in the .exe-folder.

    The problem is similar to this one: http://developer.qt.nokia.com/forums/viewthread/5310/

    I can't find out though what is going wrong...


  • Moderators

    You seem to use dropbox for transfer of your application from to the other PC.
    Two things come to my mind when seeing this.

    1. Dropbox may have some safety hooks not allowing full access. You never know what someone else sharing with ;-)
    2. You might need to set the path or another environment variable. But you probably thought of that your self.


  • nah, the 2nd PC is just a Virtual Box. They share the same folder and dropbox is not running.


  • Moderators

    So, sorry!!
    Your error listing might be a bit misleading then. ;-)



  • Yeah I should've explained it more in detail.

    I found the problem (after 5 hours) myself. I had to put the Qml Desktop-components in an imports-folder and add a qt.conf file with this content:

    @[Paths]
    Plugins = plugins
    Imports = imports@



  • I'm currently experiencing a similar problem and looking for some guidance. When I run the .exe I also get a blank screen. I have copied all the relevant dlls into the release dir, created a qt.conf file with the above info in. When I run Process Monitor I get this:

    release\imports\QtQuick.1.1 NAME NOT FOUND

    What do I need to copy into the release directory to solve this? Or is there something else that i'm missing.

    I'm using the QtDesktop components. If i remove these from the project the exe runs fine, its when the "import QtDesktop 0.1" is added, the window is blank when the exe is run.

    Process explorer isn't showing any errors with finding QtDesktop components though:

    release\imports\QtDesktop.0.1 SUCCESS

    I'm only seeing this issue when i'm building release. Debug works fine.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.