OSX System Integrity Protection and Qt .framework files



  • I had a number of Automator shell scripts running on OSX 10.8.5. After upgrading to OSX 10.12.2 Sierra, portions of the scripts stopped working. Specifically, when trying to remove Qt .framework files that aren’t needed from the .app bundle. Yes, I ran macdeployqt (5.8 version), but it add framework files I know the app does not use or need.

    The account the script is run from is an “admin” level account, so I should have the ability to run any command. The exact same command, as is attempted in the script, works fine when I open a bin/bash terminal and run it.

    I have tried the following versions from within the script..all commands are executed from the appropriate directory level..I “cd” to the folder prior to the “rm” command.

    These worked fine in 10.8.5
    rm -r -f Frameworks/QtMultimedia.framework
    rm -r -f QtMultimedia.framework

    I tried the originals as well as these variations in 10.12.2 Sierra with zero effect.
    rm -Rf Frameworks/QtMultimedia.framework
    rm -Rf QtMultimedia.framework

    rm -R Frameworks/QtMultimedia.framework
    rm -R QtMultimedia.framework

    rmdir Frameworks/QtMultimedia.framework
    rmdir QtMultimedia.framework

    It’s like the script just skips over the commands that refer to .framework “files”..I know they are really directories..with sub-directories

    Are the Qt .framework files considered some protected class of file?

    Is it Sierra and System Integrity Protection that’s causing the “problem”?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.