Is QtCreator 4.2.1 has bugs that not showing icons after adding file?



  • When adding new file or create any object file using QtCreator 4.2.1, they didn't appear after close and reload the project file.
    So, It's just missing setting of options? or just a bug?
    and if just a bug when the path is release?


  • Qt Champions 2017

    Hi
    Can you explain how to reproduce what you see ?
    If I make new project,
    right click and select add existing files
    they are added. ( every time)

    Also look in your .pro file and see if they are added.



  • Yeah "right click" and "add new file".
    I checked the .pro file after added new Sourcefile in project and already exsist about SourceFile information .
    (In this Sourcefile is all of Qt provide file)
    but there is no file icon appear in Qt Creator 4.2.1.
    and The Qt Creator have default setting after upgrade in 5.8 pack.


  • Qt Champions 2017

    • no file icon appear in Qt Creator 4.2.1.

    alt text

    Those icons?



  • yea that icon


  • Qt Champions 2017

    @laskdjlaskdj12

    Can you pro file maybe contain errors?

    Else i have no idea. not seen any posts about adding file not working.
    Using that version myself. on win 10.



  • ![alt text](0_1488022854200_upload-8bed97fb-da1a-41f5-97c6-2873142d837e image url)

    I added test_sourcefile.h & test_courcefile.cpp in Test_Project_about_icons Project right now.
    As you can see there is no icons in Proejct section.
    but in .pro file have already exsist about Headers section and Sourcefile section.

    and i tested that appear that icon is close the project and open the project.



  • oh. the Version is macOS sierra


  • Qt Champions 2017

    @laskdjlaskdj12
    oh, well pro file look ok.
    I can see the test_sourcefile so i see what you mean now.

    Are there any errors shown in compiler output when u ask it to run qmake?



  • @mrjj no Error in compiler section

    So it's so weird that Before using 4.2.0 couldn't find this issus.


  • Qt Champions 2017

    @laskdjlaskdj12
    It does seems like bug. Im complete macOS noob so not sure
    what to check next. You didnt upgrade Xcode, just QCreator ?

    I searched fast on
    https://bugreports.qt.io/
    but nothing spang to eye.



  • This post is deleted!


  • @mrjj i've upgrade all section of xcode and QtCreator and macOS version.
    and check about two different device of MBP and they have this same issus.

    and already searching this issus in google and nothing reported this at least 2016


  • Qt Champions 2017

    @laskdjlaskdj12
    Hi
    You should chekc the kits if they show errors
    http://doc.qt.io/qtcreator/creator-targets.html

    I think it might be something like
    https://geonet.esri.com/thread/165647

    Also please list the version in use
    XCode. Qt version and the MacOS version. (macOS sierra)
    That will help when the mac programmers come online.



  • @mrjj sorry that it's hard to say this can be useful answer to me because after macOS update in sierra ton of Errors appear before 5.7.1 versions.

    and also All kits Configure is fine.

    QtCreator 4.2.1
    Qt 5.8.0
    revision 7071b61e02
    sierra 10.12.3
    xcode 8.1



  • @mrjj and thankyou for kindness this problem
    i'd so stressful of this bugs


  • Qt Champions 2017

    @laskdjlaskdj12
    Dont worry. Most likely not something very bad.
    I think its not parsing the .pro file. Not sure if it uses qmake for that too but
    i assume. So it looks like its not re-parsing the file and hence nothing happens.

    Its strange however, there is no build errors and it sounds like the kits are all green too.

    When you compile, in the compiler output, does it call the tools and look overall happy?



  • @mrjj yeah this is the log after compile picture project

    Starting /Users//Desktop/QML tutorial/build-Test_Project_about_icons-Desktop_Qt_5_8_0_clang_64bit-Debug/Test_Project_about_icons.app/Contents/MacOS/Test_Project_about_icons...
    QML debugging is enabled. Only use this in a safe environment.
    qml: Clicked on background. Text: "Enter some text..."
    /Users/
    /Desktop/QML tutorial/build-Test_Project_about_icons-Desktop_Qt_5_8_0_clang_64bit-Debug/Test_Project_about_icons.app/Contents/MacOS/Test_Project_about_icons exited with code 0

    i guss QtCreator didn't hotloading anything.


  • Qt Champions 2017

    @laskdjlaskdj12
    If you make error in
    main.c
    does it catch it ?

    like
    int dummy <--- should complain about missing ;



  • @mrjj yeah catch syntes error and

    /Users/***/Desktop/QML tutorial/Test_Project_about_icons/main.cpp:11: error: expected ';' after return statement
    return app.exec()
    ^
    ;


  • Qt Champions 2017

    @laskdjlaskdj12

    So it really is alive. ( also hinted by all kits looking ok)

    But it completely ignore any new file added it seems.

    If you go to build menu and choose qmake
    and then look in compiler output.

    for me it looks like
    13:30:02: Starting: "C:\Qt\5.7\msvc2015\bin\qmake.exe" M:\dropbox_qtprojects\untitled28\untitled28.pro -spec win32-msvc2015 "CONFIG+=debug" "CONFIG+=qml_debug"
    13:30:03: The process "C:\Qt\5.7\msvc2015\bin\qmake.exe" exited normally.

    How does it look for you ?



  • @mrjj 0_1488026054707_upload-6d4d94e6-5938-4d1a-8412-2666e4acd45c

    21:34:58: Running steps for project Test_Project_about_icons...
    21:34:58: Configuration unchanged, skipping qmake step.
    21:34:58: Starting: "/usr/bin/make"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -c -pipe -stdlib=libc++ -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk -mmacosx-version-min=10.9 -g -std=gnu++11 -Wall -W -fPIC -DQT_DEPRECATED_WARNINGS -DQT_QML_DEBUG -DQT_QUICK_LIB -DQT_GUI_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I../Test_Project_about_icons -I. -I../../../Qt5.8.0/5.8/clang_64/lib/QtQuick.framework/Headers -I../../../Qt5.8.0/5.8/clang_64/lib/QtGui.framework/Headers -I../../../Qt5.8.0/5.8/clang_64/lib/QtQml.framework/Headers -I../../../Qt5.8.0/5.8/clang_64/lib/QtNetwork.framework/Headers -I../../../Qt5.8.0/5.8/clang_64/lib/QtCore.framework/Headers -I. -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks/OpenGL.framework/Headers -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks/AGL.framework/Headers -I../../../Qt5.8.0/5.8/clang_64/mkspecs/macx-clang -F/Users//Qt5.8.0/5.8/clang_64/lib -o main.o ../Test_Project_about_icons/main.cpp
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -headerpad_max_install_names -stdlib=libc++ -Wl,-syslibroot,/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk -mmacosx-version-min=10.9 -Wl,-rpath,/Users/
    /Qt5.8.0/5.8/clang_64/lib -o Test_Project_about_icons.app/Contents/MacOS/Test_Project_about_icons main.o test_sourcefile.o qrc_qml.o moc_test_sourcefile.o -F/Users/***/Qt5.8.0/5.8/clang_64/lib -framework QtQuick -framework QtQml -framework QtNetwork -framework QtCore -framework DiskArbitration -framework IOKit -framework QtGui -framework OpenGL -framework AGL
    21:34:59: The process "/usr/bin/make" exited normally.
    21:34:59: Elapsed time: 00:01.



  • @mrjj ignore about 5.6.2 android kit just lazy to remove that ..lol


  • Qt Champions 2017

    Hi
    It seems to me it it does run the moc tools on it
    (moc_test_sourcefile) so its aware of it.

    So it is looking more and more as a bug in QCreator on macOS.

    Give it a day or two. I will ask my favorite macOS person if he has heard of this.



  • @mrjj thank you mrijj

    by the way is any recruit volunteer about QtCreator translation?
    because i want to apply translation to Korean


  • Qt Champions 2017

    @laskdjlaskdj12
    Np.
    Well all can add to the Qt project. Im not sure the path for new languages for Creator but
    just make post here (in tools) and ask about how to submit then we will figure it out. :)
    If you download source for Creator , the files are in
    qt-creator\share\qtcreator\translations
    You will need to use the Qt trans tools.
    http://doc.qt.io/qt-5/internationalization.html



  • @mrjj on.. okay tanks.. and i'll leave this not solved until this is figure it out.


  • Qt Champions 2017

    @laskdjlaskdj12
    Well it might end with you filing a bug report :)



  • @mrjj oh.. i forgot about that..


  • Qt Champions 2017

    @laskdjlaskdj12

    well I would wait
    until a user that have actually used a mac for more
    than 3 mins to gives some input. :) ( as in dont take my word for it :)

    But does seem strange to me. Bug-ish.


  • Lifetime Qt Champion

    Hi,

    Which version of macOS are you using ?

    I just tested on 10.12.3 and it's working correctly.


  • Qt Champions 2017

    @SGaist
    Hi, thank you for helping
    QtCreator 4.2.1
    Qt 5.8.0
    revision 7071b61e02
    sierra 10.12.3
    xcode 8.1

    So its sierra 10.12.3 , so 100% the same it seems.



  • @SGaist is there any possible to fix it right now?


  • Lifetime Qt Champion

    You didn't answer my question about your current setup.

    Note that I can't reproduce the problem you are having on my system.

    As a side question, is your computer user account name plain ASCII or do you have UTF-8 characters in it ? I'm asking because you would like to submit Korean translation (which is very nice by the way, thank you) so I'm wondering whether the user name might trigger something in your case.



  • @SGaist my system current setup is

    QtCreator 4.2.1
    Qt 5.8.0
    revision 7071b61e02
    sierra 10.12.3
    xcode Version 8.0 (8A218a)

    and username is absolute in ASCII (username : ace)
    but it wasn't happen this issue when Qt Creator was worked in El Cap.
    and i using same user name at that moment.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.