AVDs still do not work for me



  • Hi all,

    On Windows (7 x64), I installed Android Studio 2.2.3, qt-opensource-windows-x86-android-5.8.0, SDK with these package, NDK (android-ndk-r13b), Gradle 3.3 and Java (jdk-8u121-windows-x64) and set the paths of these tools on Qt Creator like this.

    I created and tested a sample AVD and ran it successfully using this tut. And the result was fine.

    Then I edited the recently created AVD this way (because of some problems, for example, it didn't have a system image —so how Android Studio showed it successfully!!?)

    OK, after these I went for a simple example on Docs and chose that recent AVD to show the output. But the result, as always!!!

    Both the kit and AVD are of x86, so what is the problem now? I can't see the result of the apps I create :-(
    I don't know if it's of the paths, the version of java, or what?

    Thanks for your considerations.



  • I think you are using the wrong NDK. I read that the latest working NDK is release r10e.
    See https://wiki.qt.io/Qt_for_Android_known_issues



  • Well, I should tell you "Thank you very much, I'm appreciative". It worked.

    And please have a look at this screenshot; it shows a small error on the screen of the x86 AVD.

    And Android Wear has stopped for Arm AVD.



  • The problem was solved.
    The issue was about a small inappropriate work! The AVD was closed "before" turning it off and that caused that problem.
    I deleted the previous AVDs and created a new one and this one works fine.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.