Trouble with Mac OS X and Qt 4.7 x86_64 support



  • From what I've read, I have to build Qt from source to support 64-bit development and I've not yet been able to make it work.

    If I build Qt using '-arch "x86_64"' and then build Qt Creator, the IDE will run but won't build anything (complains about various missing frameworks).

    If I add the '-developer-build' flag to ./configure then nothing seems to get installed anywhere (libs, qmake, etc..)

    Has anyone put together a definitive set of instructions for Mac OS X on how to build Qt and Creator from source successfully?


  • Moderators

    So what exactly does not work when building Qt Creator?

    For now Qt Creator relies on having access to private headers in Qt. This is unfortunate, but we can not change that at this time (but we are working on improving the situation). For this access to be possible you need either a in-source build of Qt 4.7 (beta or rc for now, earlier version do not work!) or you need to run syncqt to copy over the headers.

    I hope this helps... Please provide the error messages you see if you need more detailed help.



  • Qt Creator builds fine, it just won't actually compile programs, saying it can't find the Qt frameworks or some such thing.

    Right now I'm trying to build Qt 4.7 RC1. Do I need to use the "-developer-build" flag? If so, how do I get the files to their final "install" location? When using "-developer-build" it prints a message saying that files will be put in their correct locations and that "make install" is not necessary, but that doesn't seem to work (eg. the built files never get installed anywhere).



  • I re-built Qt 4.7 (w/out "-developer-build"), ran syncqt this time, built Qt-Creator, created a simple project, added "CONFIG += x86_64", and it worked! Full 64-bit executable! Woo!

    Thank you!



  • Hey Guys i am new to Qt and trying to learn it and so i have installed the sdk 4.7.0 successfully but i just gave a shot to try a simple Hello World from the Book "GUI programming with C++" but it cant build the program it gives me this message:

    :: warning: directory '/tmp/qt-stuff-6474/source/qt-everywhere-opensource-src-4.7.0/lib' following -L not found

    I tried to set the PATH even re-installed but alas failed still have the same problem...

    Please Help me Folks...



  • By the way i forgot to tell about my OS. I use Mac os x Snow Leopard and besides the examples are running but if i check the compiling messages still there is the same message :(


  • Moderators

    bahonurn: Please create your own thread about your issue.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.