Problem with the use of MSVC compiler



  • Hello, I downloaded qt 5.8 using web installer and I choose as compiler MinGW, MSVC but I can choose only MinGW

    alt text

    As you can see.

    alt text

    alt text

    What can I do? or how I can fix it?


  • Moderators

    Why do you have all those versions installed? Are you really going to compile your code with all of these packages or you just randomly selected everything in the online installer?

    Anyway. Qt installer does not install Visual Studio. If you want to use Qt package for MSVC you'll need to install Visual Studio separately form Microsoft's site.




  • Why do you have all those versions installed? Are you really going to compile your code with all of these packages or you just randomly selected everything in the online installer?


    I do not know :) . But Use all them That's the tarjet.


    Anyway. Qt installer does not install Visual Studio. If you want to use Qt package for MSVC you'll need to install Visual Studio separately form Microsoft's site.


    I have instale Visual Studio. But now that you mention it, Visual Studio is installed on another partition.

    Here is the picture:

    alt text

    Which of these applications is the compiler?

    I mean, to include here.

    alt text

    Here the problem:

    alt text


  • Moderators

    I do not know :)

    You don't know what you want to do? It's gonna be difficult to help you do that then ;)

    The Visual C++ installation directory doesn't look healthy. There should be a lot more files and folders in that directory. The C++ compiler is missing (it's cl.exe). How did you install Visual Studio? Have you selected C++ components during installation or just went with the defaults? If I remember correctly VS installer does not have C++ selected by default (only the C#/.Net stuff). Run the Visual Studio installer again and make sure you select C++ components.

    As for Qt - you installed Qt packages for all the supported versions of Visual Studio so to make them all usable you'd have to install Visual Studio 2015 and 2013. You also have two versions of Qt there 5.7 and 5.8.

    All this is getting you nowhere and wastes a lot of your time and hard drive space.
    Start with figuring out what you want to do exactly (desktop? mobile? which platforms?) and install only the package you actually need. I doubt you need them all.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.