Trouble With XKB, Deploying Remotely



  • I am deploying a QT 5.1.0 application on a remote cluster and having trouble getting the keyboard to work. The application is run by logging into a No Machine server, then ssh into an associated remote cluster, then run the program on the remote cluster. Also the program is compiled on the remote cluster.

    When the program is executed, I get the following Error:

    failed to add default include path /usr/share/X11/xkb
    Qt: Failed to create XKB xontext
    

    I've seen proposed solutions to the same issue, setting QT_XKB_CONFIG_ROOT. I notice that /usr/share/X11 exists, but /usr/share/X11/xkb does not (on the remote cluster). Although in the no machine server, /usr/share/X11/xkb does exist, as well as <path to NX>/X11/xkb. So I've tried setting QT_XKB_CONFIG_ROOT to include all of these paths, as well as a local copy of xkb on the cluster. However, it still doesn't work.

    Is there a workaround for this problem? For example, maybe a way to change the default include path for xkb? I know I can use the bundled xkb if I compile QT from scratch, but since I have no administrative rights, and the system already has QT installed, I'd rather find another option.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.