[Solved] qt_message_output not located in QtCore4.dll



  • I'm trying to deploy a Qt app. I have copied the DLL files that I use from Qt. My directory looks like:

    @SmartLog.exe
    libgcc_s_sw2-1.dll
    mingwm10.dll
    QtCore4.dll
    QtGui4.dll
    QtNetwork4.dll
    QtSql4.dll
    QtXml4.dll
    sqldrivers/qsqlite4.dll@

    When I run my application (which runs fine on my development box) I get a windows message box stating: "The procedure entry point _Z17qt_message_output9QtMsgTypePKc could not be located in the dynamic link library QtCore4.dll"

    Any ideas how to solve this problem? Oh, I am using Qt 4.6.3.

    Thank you, Jeremy Cowgar

    [edit: solved / $chetankjain]



  • are you sure you copied libraries you've linked against?



  • That was the problem. I was copying C:\Development\Tools\Qt\2010.04\bin\QtXYZ123.dll ... I changed to copy C:\Development\Tools\Qt\2010.04\qt\bin\QtXYZ123.dll and all started working fine.

    Thank you very much!

    Jeremy



  • hi jeremy i have problem Z21qRegisterResourceDataiPKhS0_S0 is not found in QtCore4.dll plz help noy woking !!! what do i change??? :(



  • I have once faced this problem. Actually the problem was, I created a project in Qt 4.8 and tried to build the same project in a different Qt version. There will be changes in the same dll files of different Qt versions.
    Normally a Qt project contains some inbuilt classes that supports the Qt version.
    One option is to create a new project in your Qt version and import all of your files in it.
    Other option is to check these inbuilt classes, .pro files.
    Also you can install the same Qt version in your PC and can build it smoothly.
    I hope this will help you.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.