Wrong default configuration of clang++ kit on OS X



  • Same setting as in previous (resolved) topic:
    I work on a Mac (OS X 10.11.6) with Xcode (8.2.1) installed. I have just uninstalled a previous Qt Creator installation (my old Qt folder is gone). Now, I have a fresh installation created by qt-unified-mac-x64-2.0.4-online. To test the installation, I immediately opened Qt Creator and picked File|New project. Thus I created a Qt Console Application with nothing but the default contents.

    Problem:
    I can build my tiny, default project OK but I get one warning in the Issues warning me:
    "/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++" is used by qmake, but "/usr/bin/clang++" is configured in the kit.
    Please update your kit or choose a mkspec for qmake that matches your target environment better.

    How do I get rid of that warning? I have studied the kit settings but cannot find where to update the kit as suggested by the warning. Perhaps you could help me navigate to the right place in Qty Creator?



  • @NielsHolst Hi, Tools->Options->build & run->compiler has the settings you need to fix that. :)



  • I have found the reason why Qt Creator could not configure my project correctly: My .pro file depended on an environment variable. Moving from Windows to Mac and being unable to set an environment variable on the Mac (!), I resorted to set the environment variable from within Qt Creator.

    However, to be able to set the environment vaiable in Qt Creator, I had to first open the .pro file and let Qt Creator configure the project. That configuration could not be carried through correctly because the environment variable was not yet defined.

    Then when I defined the environment variable, and the .pro file should be OK, Qt Creator kept the faulty configuration.

    The way out was to rethink my project file and rid it of its dependency on the environment variable.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.