Using default flash - no dynamic loaded (Actionscript 3) content shown in flash mask



  • Hello,

    I try to load a flash swf file, which dynamically loads content from the same folder location as the swf is in.
    In my flash settings and webkit the content was just showing fine, even so the flash securtity setup required to set the folder trustet.

    In Webengine the flash content loads, but it seems that actionscript is not executed, I just get the background picture.

    I use the following QWebEngineSettings:

    QWebEngineSettings *defaultSettings = QWebEngineSettings::globalSettings();
    
        defaultSettings->setAttribute(QWebEngineSettings::PluginsEnabled, true);
        defaultSettings->setAttribute(QWebEngineSettings::ErrorPageEnabled, true);
        defaultSettings->setAttribute(QWebEngineSettings::JavascriptCanOpenWindows, false);
        defaultSettings->setAttribute(QWebEngineSettings::JavascriptCanAccessClipboard, false);
        defaultSettings->setAttribute(QWebEngineSettings::JavascriptEnabled, true);
        defaultSettings->setAttribute(QWebEngineSettings::LocalContentCanAccessFileUrls, true);
        defaultSettings->setAttribute(QWebEngineSettings::LocalContentCanAccessRemoteUrls, true);
        defaultSettings->setAttribute(QWebEngineSettings::LocalStorageEnabled, false);
        defaultSettings->setAttribute(QWebEngineSettings::AutoLoadImages, true);
        defaultSettings->setAttribute(QWebEngineSettings::AutoLoadIconsForPage, false);
        defaultSettings->setAttribute(QWebEngineSettings::TouchIconsEnabled, false);
        defaultSettings->setAttribute(QWebEngineSettings::FullScreenSupportEnabled, false);```
    

    Am I missing out on anything?

    And also a question, is Actionscript 3 ExternalInterface javascript features available in QWebengine?
    I tried to get it running in an older codebase using QWebkit, but besides the content showing, evalutateJavascript didnt trigger it.

    So I tried to get it working with QWebEngine to see if things improved.

    Any help would be appreciated.

    PS: I tried to install and use pepperflash - but it didnt work for me using the command line options:
    --ppapi-flash-version=24_0_0_189
    --ppapi-flash-path=path_to_dll/sub_path/pepflashplayer32_24_0_0_189.dll

    It says the plugin is not enable if I use that as command line arguments.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.