NMAKE : fatal error U1073: don't know how to make '..\..\..\..\include\QtPlatformSupport\5.4.1\QtPlatformSupport\private\qgenericunixeventdispatcher_p.h'



  • Hi I am trying t build the Qt 5.4.1 from the source code.

    Currently I am getting the following error:

    NMAKE : fatal error U1073: don't know how to make '........\include\QtPlatformSupport\5.4.1\QtPlatformSupport\private\qgenericunixeventdispatcher_p.h'

    NMAKE : fatal error U1077: '"c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\nmake.exe"' : return code '0x2' Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2' Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2' Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2' Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2' Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2' Stop.

    Note: I have installed Directx and configured the required environment paths .

    Please help to know the root cause of this error.

    Thank you.


  • Moderators

    @QtVik
    why are you using NMAKE for building Qt unix source file?
    How did you configure Qt??



  • Hi,
    Basically I wanted to create C++ application using Qt on MSVC complier option.
    I have downloaded the source code from the below mentioned link:
    https://download.qt.io/archive/qt/5.4/5.4.1/single/

    Followed the Readme document from the source code folder to build it.
    Document says for developer build use the following command:
    ./configure -developer-build -opensource
    After running this I get the message
    "Qt is now configured for building. Just run nmake."

    However if I run the command "make -j4 " as per the document it is not able to identify the make command.
    What setting i need to do to execute the make command ?

    Thanks :)


  • Moderators

    @QtVik said in NMAKE : fatal error U1073: don't know how to make '..\..\..\..\include\QtPlatformSupport\5.4.1\QtPlatformSupport\private\qgenericunixeventdispatcher_p.h':

    "Qt is now configured for building. Just run nmake."

    as it says, using MSVC you should run nmake instead of 'make'.
    Try again doing the following:

    nmake dist-clean
    ./configure -developer-build -opensource -platform win32-msvc2013
    nmake
    

    adapt the -platform argument to the compiler you are using.



  • I did the 'nmake distclean', configured and ran nmake again.
    The compiler that I am using is visual studio 2010.
    But no luck with that, getting the same error :

    NMAKE : fatal error U1073: don't know how to make '........\include\QtPlatformSupport\5.4.1\QtPlatformSupport\private\qgenericunixeventdispatcher_p.h'
    Stop.
    NMAKE : fatal error U1077: '"c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\nmake.exe"' : return code '0x2'Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'Stop.



  • The problem got resolved !!!
    Issue was with the source code folder path length.
    After editing folder name it got build.
    Thank you so much @raven-worx for your help :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.