QtCreator exits design mode when not desired



  • Steps to reproduce:

    1. Open any source/header file in new window
    2. Open form file in main window (it will enter design mode)
    3. Click on external window to edit the source/header file
      QtCreator will exit designer mode for it's main window, even if the file opened in external window have nothing to do with form being edited. It will show form's code and prompt "this file can only be edited in Design mode".

    Now I have to open QtCreator two times and care about which files to reload and when... any better way to work on UI and code at the same time?


  • Qt Champions 2016

    Hi
    shift + f4 , switch fast between design and code.

    1. "Click on external window to edit the source/header file"
      How did u get this external window? ( trying to see your issue)

    "this file can only be edited in Design mode" is lovely example of bad design :)
    It annoys me daily. I press UI file to check something. I press Edit to go back to
    code section, but oh no, this means I want to see the UI as text
    version that i'm not allowed to edit anyway. \o/ :)



  • In the top-right corner of code editor, there is "split" button where you can select "open in new window" option. This is what I see on step 2, I moved external window to the right:
    link to image
    Then I click on the right side to edit the code while looking at e.g. widget names on the left side. This is what is happening then:
    like to image
    So the problem is not to switch between modes; I want them both at once because before I figured that I can use two instances of QtCreator, I was using screenshots or pen and paper...


  • Qt Champions 2016

    Ahh, no. That won't work well.
    I use Designer.exe for this.

    D:\Qt\5.7\mingw53_32\bin\designer.exe

    Works much better then trying to make Creator not be epic annoying. :)



  • Oh, okay, never thought about it. Thanks, will do. :)


  • Qt Champions 2016

    @dijuna
    On windows, you can just right clock the UI file and select Open With - > Designer.
    That works ok even if slightly slower than just open :)

    Ps. Designer is multiple doc container so u can open all UI in single Designer. :)



  • @mrjj just to sort things up, "Open With - > Designer" works also on Linux and that is the approach I'm using now, thanks. :)


  • Qt Champions 2016

    @dijuna
    Super. Its good to know same way work cross platform :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.