GUI development using Qt on Windows



  • Getting started with QT for GUI application development on Windows.

    Downloaded and installed Qt 5.7.

    Created a GUI project, tried compiling and got this error.
    "
    Error while building/deploying project FirstQtApp (kit: Desktop Qt 5.7.0 MSVC2015 32bit)
    When executing step "qmake"
    "

    Do I need to install any other software packages before compiling and what is the configuration to be made?

    Please help me resolve this.

    Thanks.



  • Hi also you need Visual Studio 2015 you can download it here



  • Hi,

    I have it already installed.

    I was wondering if there is any configuration required to make it work? And if there are any other pre-requisite tools?



  • Yes, also when you install Visual Studio 2015, you need to select "Custom installation" and then choose C++.
    If you have already installed it, you can choose File New Project C++ to make it install the C++ components for you.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.