An issue with the issues tab



  • I am working on a rather large C++ code base, so I created several sessions to sort it a little bit.

    In all sessions but one the "issues" tab works as designed and everything is fine.

    Only in this one session it does not work and no compiler errors or warnings make it into the issues tab.

    My colleagues have no idea, google and stackoverflow give no real answer (yet), so I have to ask.

    I am using QtCreator 4.1.0 under Ubuntu 14.04, cmake is version 3.7.0-rc2, and clang++ says: Ubuntu clang version 3.5.0-4ubuntu2~trusty2 (tags/RELEASE_350/final) (based on LLVM 3.5.0)

    Any idea will be appreciated!!


  • Moderators

    @uwittenberg

    Hi and welcome to devnet forum

    Do you have a compile output in the associated tab?



  • Hi,

    thanks for the warm welcome!

    The answer is YES. I have lots of warnings in the compile tab that I want to see in the issues tab.

    What I don't understand is, that for all my sessions it works perfectly. Only this one does not. I have created a brand new sessions for this part of the code, but it did not help...

    I had a similar problem a few weeks ago, but that was solved with a cmake update.

    Here is an edited example of a warning that did not make it into the issues tab:

    /pathtofile/file.h:591:12: warning: private field 'm_padding' is not used [-Wunused-private-field]
    tt_slong m_padding = 0;

    Is there a formatting problem, maybe?


  • Moderators

    @uwittenberg

    Did you check the filters under issues tab?
    The yellow triangle is for filtering out warnings. However there is also the filter button one to the right. Check this one if there is a difference.
    Other than that I do not know. I think I came across the required syntax for compile output to recognize, but do not remember anymore where.



  • @koahnig Well, one of my colleauges used his magic fingers and switched the warnings off and on again (which I had done myself several times before!) and suddenly it works...

    IMHO there is a subtle bug in QtCreator which makes it lose track whether this flag is on or off in certain situations.

    Thanks for the replies!!!


  • Moderators

    @uwittenberg

    Good to know that your problem is solved.

    If it is reproducable, I can only encourage you to file a bug report. However, I guess "subtle" indicates the opposite ;)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.