Cannot start QML Emulator

  • Hi,

    I've installed qt creator 4.1.0 along with QT 5.7. I also have visual studio 2015 as well. I'm new to qt creator but I have used designer before with python.

    When every I open an example that's using control 2 I get an error when I try to open the qml file in the design tab. example (QT Quick Controls 2 - Gallyer) But I can run it and the window will appear. So it does work. I also get this error just making a new project.

    Error window:
    Cannot Start QML Emulator Layer (QML Puppet)
    the executable of the QML emulator layer (QML Puppet) process cannot be started or does not respond.

    Any ideas what would case this?

  • Does a pure Qt Quick application without controls work for you?

    You can also try to set QT_OPENGL=software in the enviroment you run Qt Creator from.

  • Just the base Qt quick app doesn't load. I tried the QT_OPENGL and that doesn't seem to work.

    I did update my video drivers and I could get to the design tab once with the demo gallery app. But the second time I tried to get to it I got the same puppet error. Now I get the error every time.

  • I've uninstalled creator 4.1 and all QT. then installed QT 4.0.3 and I get the same error.

    First tried this:

  • If you define QT_OPENGL=software then Qt Creator and the QML Emulator Layer use software rendering, so the issue seems not to be related to OpenGL. But you have to set the variable for Qt Creator itself not just in the run settings for the application.

    We use sockets to communicate with the process (qml2puppet) that does the rendering, but there are no known issues with that.
    The issues on Windows I am aware of are problems with Wacom drivers.
    Which version of Windows to you use?

  • Windows 7 Professional, I do have a wacom table...I unplugged it and restart my computer. The design tab worked once but now gives the same error.

  • Unplugging the tablet does not help. You have to at least temporarily disable the driver.
    The issue is described in detail here:

    You can stop the driver like this: net stop WTabletServicePro
    And restart the driver with this command: net start WTabletServicePro