Strange behaviour of GUI design and runtime GUI



  • Hi,
    I have a project in which I created a GUI 2-3 months ago. It worked and still works very well. Now I decided to add some other elements such as buttons, text fields on GUI. In Qt Designer 4.0.3 I added the elements but if I run the program I don't see the new elements. It shows only old elements that previously (2-3 months ago) added.
    I bakced up and deleted *.ui file, the projects is of course not compiled. I backed up and deleted *.pro.user file, still the same, and there is no "Layout".
    Im adding pictures to explain clearly:

    In Qt Designer:

    alt text

    In Runtime exe:

    alt text

    What can be wrong?
    Thanks.



  • Ohh sorry, I forget to log in.



  • Try re-running qmake (build->run qmake in Qt Creator) and/or deleting the build directory



  • I forget to mention it. I cleaned the project, build directory, I re-run the qmake and re-build. Still same.


  • Moderators

    @kahlenberg Probably the build directory is still the old one ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.