Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How disable Native Debugging



  • Hi, i'm new with QtCreator, i'm trying to do a debugging of my code, but the debug is in ASM, i change in Tools->Build & Run->Kit , the Debug to GDB but ever the same, this is my screenshot:

    alt text

    What can i do?

    This is my easy Code:

    #include "notepad.h"
    
    Notepad::Notepad()
    {
        textEdit = new QTextEdit;
        quitButton = new QPushButton(tr("Quit"));
    
        connect(quitButton, SIGNAL (clicked()), this, SLOT (quit()));
        QVBoxLayout *layout = new QVBoxLayout;
    
        layout->addWidget(textEdit);
        layout->addWidget(quitButton);
    
        setLayout(layout);
    
        setWindowTitle(tr("Notepad"));
    
    
    }
    
    int main(int argv, char  **args){
        Notepad *m = new Notepad();
    }
    

  • Moderators

    Hi,
    Open the Debug menu and make sure the "Operate by Instruction" option is not checked. Note though, that if you happen to break in code you don't have the source for, you will still see the assembly (because that's all you've got). Take a look at the stack window. Identify your code there and double-click it to jump up the stack.



  • Sorry, but i don't find this...

    This is my Debuggers Menu:
    alt text



  • You are in Release mode. Go to Debug mode (left bar, at the bottom there is a selector to select which kind of build and which target to run)



  • I set Debug Mode, but ever this


  • Moderators

    I said "Debug menu", not Debugger tab in the Options dialog. The one in the main window, on the top menu bar, next to "File", "Edit", "Build" and so on.


  • Lifetime Qt Champion



  • Operate by Instruction is not checked...

    When i do debug i have this errors:
    alt text



  • Im not sure about *.pro configuration files, I usually use CMake project. With CMake I have those errors when I try to debug a build without debug symbols. Maybe you have to check the *pro file to be sure that in Debug mode, its building the debug symbols.


Log in to reply