Qt Creator cannot build anything...



  • I have Qt Creator, from the About dialog:

    Qt Creator 3.6.1
    Based on Qt 5.6.0 (GCC 4.9.1 20140922 (Red Hat 4.9.1-10), 64 bit)

    Built on Mar 14 2016 09:35:54

    From revision 5587df79a1

    I have been working for months on a number of projects which until today compiled without problems, I am using Qt 5.6.0, sometime this morning an error has occurred. At first glance I thought it was something in my project, however having searched and compared versions in Git I could not find any problems. I then tried to build other projects and the same errors came up. I then sought help in-house from another Qt developer we tried building one of the examples 'terminal' this also now shows the same errors, for some unexplained reason I cannot build any projects on my development system.

    I'm using Red Hat Enterprise Linux Workstation release 7.2 (Maipo)

    I did a RedHat system update earlier today, however I had compiled and build projects post this update, then all of a sudden something has happened that stops the build process, typical errors displayed when trying to build:

    In file included from /home/fcs/Qt/5.6/gcc_64/include/QtCore/qcoreapplication.h:40:0,
    from /home/fcs/Qt/5.6/gcc_64/include/QtWidgets/qapplication.h:37,
    from /home/fcs/Qt/5.6/gcc_64/include/QtWidgets/QApplication:1,
    from ../terminal/main.cpp:35:
    /home/fcs/Qt/5.6/gcc_64/include/QtCore/qobject.h:90:17: error: field 'children' has incomplete type
    QObjectList children;
    ^
    /home/fcs/Qt/5.6/gcc_64/include/QtCore/qobject.h: In member function 'const QObjectList& QObject::children() const':
    /home/fcs/Qt/5.6/gcc_64/include/QtCore/qobject.h:190:64: error: 'class QObjectData' has no member named 'children'
    inline const QObjectList &children() const { return d_ptr->children; }

    Is there a clean up or built in integrity check/repair tool I can run that will fix whatever is wrong?

    [Edit]

    I am currently running the Qt Maintenance tool, hoping that this will find and resolve any issues, it is presently downloading 1.2GB of updates.

    [Edit #2]
    Happy to say after running the Maintenance tool everything now builds again.

    Thank you,
    Simon



  • This post is deleted!

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.