Camera Example - no service found



  • So, when I try run "Camera Example" I have this error on my terminal in raspberry:

    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.camera"
    

    Of course I install many gstreamer libraries but nothing happens and I don't have many left hard space on this memory card so I need help.
    Anyone know what exactly library I need to install?


  • Lifetime Qt Champion

    Hi,

    What version of gstreamer did you install ?



  • Well I have some packages v.0.10 and v.1.0.
    If I write "gstream" in my synaptic in raspberry I see these installed packs:
    gstream v.0.10 packages:

    gir1.2-gstreamer-0.10
    gstreamer0.10-alsa
    gstreamer0.10-gconf
    gstreamer0.10-x
    gstreamer0.10-plugins-bad
    gstreamer0.10-plugins-base
    gstreamer0.10-plugins-good
    gstreamer0.10-plugins-ugly
    libgstreamer-plugins-bad0.10-0
    libgstreamer-plugins-bad0.10-dev
    libgstreamer-plugins-base0.10-0
    libgstreamer-plugins-base0.10-dev
    libgstreamer0.10-0
    libgstreamer0.10-dev
    

    gstream v.1.0 packages:

    gir1.2-gstreamer-1.0
    gstreamer1.0-alsa
    gstreamer1.0-plugins-bad
    gstreamer1.0-plugins-base
    gstreamer1.0-plugins-good
    gstreamer1.0-plugins-ugly
    gstreamer1.0-libav
    gstreamer1.0-omx
    gstreamer1.0-x
    libgstreamer-plugins-bad1.0-0
    libgstreamer-plugins-bad1.0-dev
    libgstreamer-plugins-base1.0-0
    libgstreamer-plugins-base1.0-dev
    libgstreamer1.0-0
    libgstreamer1.0-dev
    

  • Lifetime Qt Champion

    Strange, that looks pretty complete. How are you connecting your camera ?



  • Well, I connect camera into my usb from rpi. I use vncviewer to get raspberry display on my ubuntu and then I run this program.


  • Lifetime Qt Champion

    What brand of camera is it ?




  • Lifetime Qt Champion

    How did you install Qt on your Pi ?
    Which version is it ?



  • Well, I had a short break...
    First of all I forget tell that I using cross-compiling for my raspberry.
    I installed only few Qt modules for Pi, which this example uses, because as I said I don't have many free disk space.
    So, these are my Qt modules installed by synaptic:
    version:

    5.3.2+dfsg+4+rpi1
    

    Modules:

    libqt5core5a
    libqt5dbus5
    libqt5gui5
    libqt5network5
    libqt5opengl5
    libqt5widgets5
    libqt5multimedia5
    libqt5multimediawidgets5
    

    Maybe this is my fault but I don't see any place where I can download the newest Qt for 32-bit systems.
    But all other examples which I tested, seem to be fine.


  • Lifetime Qt Champion

    Did you check whether the gstreamer backend was properly built and installed ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.