Failed to get WebGL context in QWebEngineView on Windows 8.1 64bit



  • Hi,

    I am building a Qt application that communicates and displays a web application which use WebGL , it all work fine on Windows 7 and 10 but on Windows 8.1 the application opens correctly and displays the web application fine except the WebGL part which fails to run cause it can't get the WebGL context and fails at this line :

    var gl = canvas.getContext("experimental-webgl")
    

    that's only happens on the application as I tested the web application separately on Windows 8.1 and it worked just fine on both Google Chrome and IE.

    What I have tried so far :

    • I tried checking with Dependency Walker to find any missing DLLs and managed to get all the missing DLLs except this one :

    "EXT-MS-WIN-MF-PAL-L1-1-0.DLL"

    I couldn't find it anywhere and couldn't find any information regarding why the application needs it as I couldn't find any reference to the routines called inside it , however I don't think this is what causing this problem as I checked the missing dlls on both Windows 7 and 10 they are also missing the same DLL file but the application run fine on them.

    • I tried installing Microsoft SDK since the missing DLL seems to be related to Microsoft and Windows.
    • I tried installing vcredist_x86 together with vcredist_x64 (Visual C++ Redistributable for the same version of Microsoft compiler I am using for the Qt project).
    • While I was reading in Qt deployment pages I found that the system may use the file :
      "D3DCompiler_XX.dll"
      that is found in the system instead of the one I supplied if the one in the Windows is more updated but I think that this shouldn't be the problem , Am I right ?

    • I thought that maybe the Windows is using the Default OpenGL version but if that the case the web app shouldn't run correctly on Google Chrome or IE , Am I right ?
      And since I can't access the machine on which this problem occurred plus I don't want to install Windows 8.1 on this machine I am using VBox to test the application on Windows 8.1 which I don't know what version of OpenGL is running on.

    Any help would be greatly appreciated.

    Thank you.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.