Problems with installation on Linux



  • Believe me I tried everything what I found on Internet.
    So I downloaded the package Qt_SDK_Lin32_offline_v1_1_2_en.run set up the "runable" option. Just after the applications started there was a pop-up "Instal c++ compiler". So I closed install package and I went to KPackageKit and installed g++4.4, gcc4.4, gcc-4.5-arm-linux-gnueabi-base and gcc-4.5-base (The GNU Compiler Collection base package). Then I start Qt installation again but I still had pop-up "Install c++ compiler". I installed Qt anyway...
    In Tools->Options->Qt I have Desktop and Simulator with paths to qmake
    @/home/user/QtSDK/Desktop/Qt/473/gcc/bin/qmake@

    In tool chain I set (in Manual) gcc and I choose g++ from @/usr/bin/g++4.4@

    So without setting toolchain I cant even build project (no toolchain error), but after setting it up I have
    @make: g++ not found
    The process "/usr/bin/make" exited with code 2.
    Error while building project untitled3 (target: Desktop)
    When executing build step 'Make'
    @

    Please help me!

    P.S
    When I run SDK Maintaince Tool i still have "Install c++ compiler" pop-up



  • Hi Luka,

    Which distribution are you using? Take a look if there is a symbolic link like

    @
    /usr/bin/g++ -> /usr/bin/g++-4.4
    @

    that should be enough. It is usually automatically detected by creator, but it seems it wasn't in you case.

    Just to check: in you system, is it /usr/bin/g++4.4, without the "-" between g++ and the version number?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.