How to deal with Qaxobject with "no such property in ..."



  • As far as I know, one way to use Activex on QT is to set it with Qaxobject.

    And here I get stuck with ActiveX “webbrowser”,which is an embedded control (with UUID:{})on C#.

    Everything is Ok except for several missing "propertys".
    For example, if there is an object called "web1" from ActiveX “webbrowser”, I can call "DocumentText" this way on C#:

    string str1=web1.DocumentText;
    

    Now transfering it to QT, I guess I need to put it this way:

    QString str1 = web1->property("DocumentText");
    

    ---maybe not grammatically correct.

    But it fails,giving tips:"There is no such property in ...".

    Then I tried to wrap out all properties , methods through :

    #include <QFile>
    QString myDoc = ui.web1->generateDocumentation();
    	QFile myOutFile("D:/file.html");
    	myOutFile.open(QIODevice::WriteOnly | QIODevice::Append);
    	QTextStream ts(&myOutFile);
    	ts << myDoc << endl;
    

    As expected, there is no such property I can use.
    But would there be some nickname of such property? Indeed, Some propety like "IsBusy" is called "Busy" in QT....

    Some property called "web1.Document.Window.Frame" on C# would be called like"web1.Document.Frame"----just an example ,not grammatically correct.

    And the finding job is really frustrating, as I still get stuck with several missing properties.

    Is there some official way to solve this problem?

    tips: I've googled thoroughly for the problem, and have nothing useful found.

    I hope there is a way to solve it,with QT . I donot want to go with C# from scrach.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.