SOLVED: reinstalling after changing system hard drive



  • Hi -

    Today I put a new drive in my system. I thought I'd restored everything properly, but when I try to open a project, I get the following message:

    bq. No valid qt versions found.
    Please add a qt version in Tools/Options or via the maintenance tool of the SDK.

    What exactly does this mean? I have Qt in my tools directory.

    Thanks.

    EDIT:

    After a little more looking, it appears (though I'm not sure) that path to the qmake location might be the trouble. In Preferences-> Qt4, the qmake location shows as "<not found>" for Qt in PATH. I checked in my terminal, and PATH seems to be correct.

    Any ideas what I need to do to get going again?


  • Moderators

    You could add the path to your qmake in qt creator.

    Tools > options > tab qt4 > add button and add that location.
    You can even set it as the default.

    I hope this helps.



  • As Eddy says, just tell Qt-Creator where your Qt4's qmake executable is.



  • Thanks for the replies, guys. I noticed late last night that a whole bunch of files seem to be missing; I guess my restore wasn't as good as I'd hoped.

    I'm going to reinstall Qt from scratch right now; we'll see whether that fixes the problem.

    EDIT:

    OK, Now I'm getting a warning at the start of the SDK installation:

    bq. You need a C++ compiler to be able install the Qt SDK. Please install the latest Xcode first before invoking this installer!

    I have two problems with this:

    1. I never needed the newest version of Xcode before. I do have Xcode installed; just an earlier version. The latest has a cost.
    2. I had been using gcc as my compiler anyway.

    Ignoring that, I also get a warning that the installation path must not contain any space. For real? Does this include the name of my drive?

    Thanks for any help; I want to try to do this right.

    EDIT AGAIN:

    OK, I think I've obviated the above problems by re-installing XCode and changing my PATH variable. I can successfully (I think) invoke the compiler from Creator. Stand by for more dumb questions...



  • Did you install XCode or just restore from the backup? If just restored, it could be that some binaries in /usr/bin are missing. I would try to do a regular installation of XCode then.

    There should be various gcc-xxx binaries and symlinks in /usr/bin.

    XCode 3.x is sufficient, I have 3.2.x running here and everything is fine.



  • Hi, Volker –

    Yeah, I did a restore (from a TM backup). Evidently a LOT of stuff was missing...I wonder what other time bombs await me down the road.

    Anyway, I did reinstall XCode from the Apple binary, and it seems to be working OK now. I'm still a little surprised that I had to manually add the path in preferences; I'd feel better if it had successfully auto-detected it. But, I guess I can live with it.

    Thanks...



  • Timemachine is somewhat problematic. It silently removes old stuff if it runs out of space and needs to save new stuff. So you might end up with an incomplete backup.



  • That sounds like a disaster waiting to happen. Is TM supposed to be a proper backup mechanism or just a convenience? (Serious question since I do not have much experience with Mac)



  • [quote author="ZapB" date="1308849102"]That sounds like a disaster waiting to happen. Is TM supposed to be a proper backup mechanism or just a convenience? (Serious question since I do not have much experience with Mac)[/quote]

    Eh...it's somewhere in between. Most people (including me) keep their TM volumes on drives large enough to never fill up. Once TM has made its initial backup, it's remarkably efficient on disk space. That's why I'm pretty sure this wasn't my issue.

    That said, as great as TM is (and it's saved my bacon more than once), there's a lot of room for improvement. Hopefully when Lion comes out next month, it will feature some of these improvements.



  • Doesn't sound as if TM provides anything that rsync + hard links can't. ;-)



  • [quote author="ZapB" date="1308849522"]Doesn't sound as if TM provides anything that rsync + hard links can't. ;-)[/quote]

    Except for ease of use for the masses.



  • True. Maybe someone should wrap up rsync in an optional shiny GUI - maybe one that looks like a DeLorean ;-)



  • Well, I thought I was fixed, but...now I'm getting an error:

    bq. make: *** No rule to make target /Volumes/750 GB/Users/mzimmers/wideband/SoC simulator/simulatorGUI/DemodShaperFilter.qml', needed bysimulatorGUI.app/Contents/MacOS/DemodShaperFilter.qml'. Stop.

    The volume 750 GB is the old one; evidently, it's hard-coded somewhere inside my build preferences, but I can't find where. Any ideas?

    Thanks...



  • Have you regenerated the Makefiles by re-running qmake?



  • [quote author="ZapB" date="1308936381"]Have you regenerated the Makefiles by re-running qmake?[/quote]

    Aargh...I always forget that step. I had done a clean, but obviously that wasn't sufficient. Thanks, Zap.



  • To get a clean build I usually do:

    @
    make distclean
    @

    followed by the usual

    @
    qmake -r
    make
    make install (if needed)
    @


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.