Qt 5.7 OSX macdeployqt problems with QtWebEngine via Qml



  • I can build my app perfectly fine via QtCreator, or the command line and it runs perfectly well.

    I build on Windows, Linux, and OSX.

    On Windows I can run the deployment tool and create a package that distributes to non-Qt machines and it works great.

    I haven't done deployment to linux yet (that's after OSX.)

    When I run the deployment tool on OSX, I get a weird result.

    The resulting app bundle runs, and many aspects of my Qml work fine, all resources present, UI is correct, just about everything works - UNTIL I click on a button that dynamically adds in a Web view (I'm using QtWebEngine) - and then CRASH - instantly.

    The crash happens in my code (C++) calling ::setParentItem when I'm attaching my new Qml Component (containing a WebView as a child) - if I run this bundle from QtCreator I can see an error message from Qt claiming (right after the setParentItem call) that the 'qml object is not ready.' Now, both QtComponents, the component the object is being added to, and the component being added report their status as ready.

    Again, this works perfectly fine before I package it for deployment. All the rest of my application code works fine (and also does this exact same type of 'create component and then attach component' in exactly the same way.)

    Does this ring a bell with anyone?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.