Missing libqtdesigner.so during integration to Eclipse



  • Hello,

    I'm trying to integrate QT Jambi libraries and QTDesigner into Eclipse Indigo IDE running on Debian 6.0.1 (Squeeze) OS, because I would like to use QTDesigner inside Eclipse.

    There were no problems with libraries but when I 'm setting the location of QTJambi installation to Eclipse (Window->Preferences->QTJambi Preference Page) I get an error that libqtdesigner.so is missing. I was trying to find it on the internet but I did not succeed.

    Then I launched Windows 7 Ultimate and used the same Eclipse version and I got practically the same error. qtdesigner.dll was missing. I found it on the internet, copied it into installation directory of QTJambi. The validation in the preferrence window of Eclipse was successfull but then the QTDesigner perspective did not work at all.

    Could somebody help me with this problem? Do I need the file or is it possible to make it in other way? Or is it possible to integrate it into NetBeans?

    Thanks very much for response :)





  • Thank you very much... I finally have found the necessary files in the link that you posted:) I had to rename the libQtDesigner.so to libqtdesigner.so because Eclipse requested that filename. Now it works. :)

    Now, I´m facing the other problem ... how to get a java source code from the designer´s .ui file. I don´t know if my vision is right, but I would like to design the application in QTDesigner and obtain a source code in java like for example in NetBeans Designer for Swing. Is it possible? Or I have to work only with the XML code?

    P.S.: the problem is that I can write the code and use the API. Now only the IDE is the problem :)



  • So finally the problem was resolved.

    I created a .ui file in QTDesigner. Then I edited the file as follows:

    1, I removed the first line (declaration of XML, localisation settings etc.)

    2, And the second line from:

    @<ui version="4.0" language="jambi">@

    to:

    @<ui version="4.0" language="jambi">@

    3, I renamed the file from <filename>.ui to <filename>.jui

    4, Finally I passed the .jui file to juic and it transformed it into java code (<filename>. java).
    It wasn´t necessary because if I passed the .jui file to Eclipse, it created the .java file immediately.

    I know that this resolution is not very elegant but I haven´t got enough time to find the problem why the designer didn´t work in Eclipse :)


  • Moderators

    What's the difference between

    bq. <ui version="4.0" language="jambi">
    to:
    <ui version="4.0" language="jambi">

    ? ;)



  • Ou... I´m sorry it is like this :
    from:

    @<ui version=“4.0”>@

    to:

    @<ui version=“4.0” language=“jambi”>@

    Now it´s okay:) Thanks for correction :)


  • Moderators

    No problem. Thanks for sharing!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.