[Solved] The Qt version is invalid: Qt version is not properly installed, please run make install -- How to fix?



  • Hi,

    I installed Qt Creator 2.2.1 on Ubuntu 11.04 from this website. The file I used: Qt Creator 2.2.1 for Linux/X11 64-bit (82 MB)

    When I tried to build the application I got an error that qmake is missing. So I installed qmake from repository using the following command:

    sudo apt-get install qt4-qmake

    Now, when I build the application I get this error: The Qt version is invalid: Qt version is not properly installed, please run make install.

    How do I resolve it? I would prefer not to install the whole SDK as I am not developing Qt applications. I assume this is possible since Qt Creator is offered as a stand alone application.

    Thanks again!


  • Moderators

    qt Creator 2.2.1 needs a higher qmake version to build than the one you get from your ubuntu package.

    I guess you need the sdk to get a higher version of qmake.

    I had that message before, but i remember it told me what version i needed at least.

    .



  • Not sure you can use Qt Creator without Qt. Are you using a .pro file to define your project? In that case you need to remove the default dependencies on the core and gui modules:
    @QT -= core gui@
    But I'm not sure that will be enough.


  • Moderators

    You could just install the Qt library to get a higher version of qmake. Not the complete sdk.

    Don't forget to alter your PATH to the new qmake directory.



  • I see,

    Is qmake the only file I need?

    I am downloading Qt Library to get qmake, then I am thinking to uninstall the library.

    THX!


  • Moderators

    bq. Is qmake the only file I need?
    I am downloading Qt Library to get qmake, then I am thinking to uninstall the library.

    why would you want to uninstall the library? I think you will get dependencies messed up



  • From README
    [quote]
    Building the sources requires Qt 4.7.1 or later.
    [/quote]

    Edit: My Ubuntu 10.04 installation has 4.6.2 as the latest version, so no you can't remove the library, you need to build against it.



  • I am not doing any Qt development, I am working on algorithms. I'd like to use Qt Creator as my IDE on Ubuntu and since it is offered on its own I tend to believe I will be able to run it without any Qt libraries or SDK.

    So, I think I can use Qt Creator without Qt libraries.

    Can I use qmake without Qt libraries? Or, do I have to replace qmake with cmake?

    Thank you.



  • Qt Creator is using the Qt Framework so you need at least Qt 4.7.1 to run it.



  • [quote author="loladiro" date="1308683912"]Qt Creator is using the Qt Framework so you need at least Qt 4.7.1 to run it.[/quote]

    Just to run Qt Creator? I am running it right now without installing any libraries.



  • Well, Ubuntu installed Qt 4.6 for you which is enough to run your old version of Qt Creator.



  • Phew, I (almost) understand now. Thank you.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.