[SOLVED] SSL library not loading on some machines



  • I've been having trouble trying to identify a problem regarding SSL library and QT. In my own environment eveything works fine, but I have trouble loading the OpenSSL library on some virtual Windows machines.

    QT and OpenSSL are both dynamically linked, ie. dll's are present in the application directory. OpenSSL DLL's are there (libeay32.dll, libssl32.dll and ssleay32.dll). Still I get the error:

    SSL library not loaded
    

    when trying to connect to SSL encrypted server with QSslSocket.

    Now as I said, it works on most of the machines, and in my own environment aswell, so for now I won't post actual code examples (it shouldn't be error in the code itself, but in the way QT loads the OpenSSL library). The problem is only occuring on some virtually hosted Windows machines, somehow when running my application there, Qt doesn't find (or is unable to load) the SSL library. I have tried to search for ways to debug this, but I haven't found any.

    • Is there any way to force QT to load the SSL library from certain path? I'm trying to identify if the problem is that QT is trying to load it from different path other than the application directory
    • Is there any debug trace that could further tell me why QT can't load the library?
    • The OpenSSL library DLLs I have been using is from 2014, could it be the problem? Maybe they are incompatible with the environment somehow?

    EDIT: Oh and I forgot, I use Qt 5.1.1

    EDIT2: Well, I should have tried this before even asking :D Updating the OpenSSL library to latest version did the trick :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.