Offline installer on debian squeeze


  • Moderators

    I tried the offline installer to install qt on debian squeeze but got no success using the installation procedure explained there.

    Has anyone succeeded in using the installer on debian squeeze yet? I'm asking because after some googling i read the offline installer is made solely for (k)ubuntu. On the other hand i read the offline installer should work on linux in general, whatever distribution.

    So if someone installed on debian squeeze using the offline installer, i would be very greatfull to hear it.


  • Moderators

    So far no reaction yet. So we can come to the conclusion the installer cannot be used on Debian....?
    Or nobody on devnet uses Debian...

    I've posted a wiki article on how to build Qt on Debian squeeze in the wiki :
    http://developer.qt.nokia.com/wiki/Howto_compile_Qt_and_friends_on_Debian_Squeeze


  • Moderators

    Did you get an error message or some hint as to what is stopping the installer from succeeding on debian?


  • Moderators

    No i didn't get any error messages. it just didn't launch.

    Could be some dependencies were not right.

    I will try again knowing i added some packages using
    @apt-get build-dep qt4-qmake@

    And those were not present before.


  • Moderators

    Just tried again and the installer launches! But i stopped it because i didn' t want 2 installations of the same.

    My Debian box is not "virgin" anymore. So i cannot test if the previous
    @apt-get build-dep qt4-qmake@
    is enough to get all dependencies.

    Maybe someone else can try it in the future with a virgin Debian installation?

    Nevertheless I had fun compiling like in the good old days. Guess we are a little spoiled by using the installers. Thanks for them!


  • Moderators

    No idea what is going wrong then:-(

    Debian tends to have library versions a bit older than ubuntu, maybe some incompatibilities between library versions is to blame here?

    What does "ldd /path/to/installer" say? Does it list any missing libraries?


  • Moderators

    Hi Tobias,

    bq. No idea what is going wrong then:-(

    I think that i didn't make myself clear enough. The installer is running now. I even could go trough the custom choice, but I disrupted it myself. So now on my system it is working!

    What I think is you need to do apt-get build-dep qt4-qmake first to get all the dependencies for qmake. I didn't do that when I tried the installer the first time. And I can't test it anymore myself because I installed several other packages that can have solved it.

    Could be a good idea to put a line in the download page of the installer to check your dependencies first and a link to : http://doc.qt.nokia.com/4.7/requirements-x11.html

    http://qt.nokia.com/downloads/sdk-linux-x11-64bit-cpp
    The download page only shows the following at this moment:

    bq. Qt SDK for Open Source C++ development on Linux/X11 64-bit
    If download doesn't start automatically, click: http://get.qt.nokia.com/qtsdk/Qt_SDK_Lin64_online_v1_1_2_en.run
    On Linux/Unix, you need to make the file executable in order to run it. You can either do this with your desktop's file manager or, at the command line, type:
    chmod u+x Qt_SDK_Lin64_online_v1_1_2_en.bin
    You should now be able to execute the file as normal. You can do this from the command line by typing:
    ./Qt_SDK_Lin64_online_v1_1_2_en.bin

    BTW : i think there is a typo here :
    the filename extension is .run and not .bin as mentioned in the text above.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.