Need QtDesigner 4.7.3 built with mingw32-g++ so I can load my plugins



  • I have determined that the Designer installed was built with msvc. I have built my plugins with mingw32-g++. I have followed multiple posts to build designer with mingw, sadly all attempts fail at one point or another. Here is the message reported by:

    Tools->Form Editor->About Qt Designer plugins

    The plugin 'C:/Qt-3rd-Party-Plugins/plugins/designer/qwt_designer_plugin.dll' uses incompatible Qt library. Expected build key "Windows msvc release full-config", got "Windows mingw release full-config"

    Is there a download for a pre-built designer that was built with mingw32-g++?

    Or has someone written a step-by-step procedure to build 4.7.3 with mingw32-g++ SUCESSFULLY?

    If I can resolve this I may be ready to spring for a Commercial License. On that note, the Commercial License does support mingw32-g++ toolchain, right?



  • Do you mean Qt Creator or just Qt Designer? Both are available in source and should compile without problems. Should you encounter any specific problems while building, feel free to ask and we may be able to help.

    Also, yes the commercial license supports mingw32, but why would you need a commercial license? Normally LGPL should be enough (as long as you are willing to share changes you make to Qt's source code).

    That being said, this is a community forum and it won't really make anybody help you faster if you plan to buy a commerical license ;)



  • Why not just use the installer? "Qt 4.7.3 MinGW":http://qt.nokia.com/downloads/windows-cpp

    [Edit: @Scylla: He does say he needs Qt Designer :P, but by the menu options used to check for plugins, you're right in that he is using Qt Creator.. ]



  • bq. Why not just use the installer? Qt 4.7.3 MinGW [qt.nokia.com]

    Because he wants the QtCreator compiled with mingw.

    If you want QtCreator compiled with mingw32, you have to download the source and compile it with mingw32, nothing more.



  • I was asking for assistance because building from source results in errors.

    Here is what I get trying to build QtCreator:

    mingw32-make[4]: *** No rule to make target ../../../qt-creator-2.2.0-src/src/plugins/coreplugin/Core.pluginspec', needed by......\lib
    qtcreator\plugins\Nokia\Core.dll'. Stop.

    I have followed several peoples posts on how to build Qt 4.7.3 everywhere opensource and
    QtCreator 2.2.0, however each time there is some issue preventing success.

    Maybe an older release might be easier to build.



  • Have you tried to use a clean source tree or "qmake -r"?



  • Turns out QtCreator source for 2.2.0 will not build if you try to build in a fresh build directory (i.e. qt-creator-2.2.0-build).

    The Makefile.Release files in the plugin directories are missing a ".." to get to the makespec files.

    This issue does not occur if you build in the unzip source directory.



  • I can't reproduce that. I used a clean source tree from and was able to build out-of source on both windows and linux. However i remember having similar problems with older version of Qt Creator. Can you try to the current version of Qt Creator (from qt.gitorious.org) and see if you still have those problems?


  • Moderators

    bq. Turns out QtCreator source for 2.2.0 will not build if you try to build in a fresh build directory (i.e. qt-creator-2.2.0-build).

    I second loladiro : i built in another directory to keep everything clean. And it works here also.



  • I recently had a problem with Qt 4.7.3 on x64 on Linux in a custom location and noticed that configure needs the "prefix" option..

    @ ./configure -prefix <path_to_my_qt_dir> @

    I speculate this might be the problem in your case too, because the error I used to get was when trying to use qmake after the compilation was also about not being able to find the makespecs..


  • Moderators

    Yes that could be the problem. I read somewhere... It's advised to build Qt Creator in a separate directory.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.