libGL error using Qt Creator on Fedora



  • Hello,

    I was using Qt 5, Qt Quick with Qt Creator 3.6 on OS Linux Fedora 22.
    My application is empty, it's just a "hello world". It display a windows with "Hello world" inside.
    It's compiling without error, but at execution, with Qt Creator, it display this error :

    Starting /home/*****************************/Test_QML_001/build-Test_001-Desktop_Qt5-Release/Test_001...
    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast
    Unrecognized OpenGL version
    Unrecognized OpenGL version

    When I click on my executable, it start well, but not with Qt Creator...

    I don't see what is wrong in my configuration...

    It's not a Qt problem, it appends same error message with another Qt 4.8-OpenGL application...

    Can you help me ?


  • Qt Champions 2016

    Hi and welcome
    Im not using fedora but it does sounds like it dont see your hardware version
    of opengl.
    Can you check with Gears or any other opengl app that it can run accelerated?

    http://askubuntu.com/questions/541343/problems-with-libgl-fbconfigs-swrast-through-each-update



  • If you are using Fedora through VBOX then you will have to disable the 3D Acceleration under display setting



  • Hello @FlacoDanziger, thank's for your nice link...

    Here are my libGL.so files :
    /usr/lib/libGL.so.1.2.0
    /usr/lib/libGL.so.1 -> libGL.so.1.2.0
    /usr/lib/nvidia/libGL.so.358.16
    /usr/lib/nvidia/libGL.so -> libGL.so.358.16
    /usr/lib/nvidia/libGL.so.1 -> libGL.so.358.16
    /usr/lib64/libGL.so.1.2.0
    /usr/lib64/libGL.so -> libGL.so.1.2.0
    /usr/lib64/libGL.so.1 -> libGL.so.1.2.0
    /usr/lib64/nvidia/libGL.so.358.16
    /usr/lib64/nvidia/libGL.so -> libGL.so.358.16
    /usr/lib64/nvidia/libGL.so.1 -> libGL.so.358.16

    Reading your ubuntu link, I have to change a symbolic link, but I don't understand wich I must to change ? I have to delete libGL.so.358.16 symbolic link to /usr/lib64/nvidia/libGL.so.1 to make it to /usr/lib/libGL.so.1.2.0 ?

    GlxGears works well, I don't want to break my system... :-/

    I'm not using VBOX



  • For information, of I type ldd on my application and QtCreator it produce theses results :

    ldd Test_001 | grep libGL
    libGL.so.1 => /usr/lib64/nvidia/libGL.so.1 (0x00007f03bd777000)

    ldd /usr/bin/qtcreator | grep libGL
    libGL.so.1 => /usr/lib64/nvidia/libGL.so.1 (0x00007f045121d000)

    Both two application above don't use :

    /usr/lib/libGL

    I don't see where is the problem and how to fix it ... :-/


  • Qt Champions 2016

    @CutiUser
    what does ldd Gear say?



  • what does ldd Gear say?

    ldd /usr/bin/glxgears

    libGL.so.1 => /usr/lib64/nvidia/libGL.so.1 (0x00007fdd51fb9000)
    libX11.so.6 => /lib64/libX11.so.6 (0x0000003c3e800000)
    libnvidia-tls.so.358.16 => /usr/lib64/nvidia/tls/libnvidia-tls.so.358.16 (0x00007fdd51db3000)
    libnvidia-glcore.so.358.16 => /usr/lib64/nvidia/libnvidia-glcore.so.358.16 (0x00007fdd50152000)

    glxgears and my Qt compiled GL programs works well.
    The problem is just when I try to start my projects using Qt creator start button :-(
    I have just downloaded Qt Creator 4.0 and it's the same problem...



  • No more ideas ?



  • HI, just a wild guess, but try disabling some plugins (in the list in Qt Creator's About Plugins), first test with disabling the Welcome plugin, then exit and start Qt Creator again, and then see if launching your app works any better.



  • Thank's hskoglung, but it doesn't work.

    A friend tell me to try this command line "export LD_LIBRARY_PATH=/usr/lib64/nvidia:${LD_LIBRARY_PATH}", but it doen't work too. I have always this message :
    Starting /home/xxxxxxxxxxxxxxxxxxxxxx/Test_QML_001/build-Test_001-Desktop_Qt5-Release/Test_001...
    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast
    Unrecognized OpenGL version
    Unrecognized OpenGL version
    ... when I click on Qt Creator "Run button"... :-/



  • Hi,

    I had the same problem on an openSUSE 42.1 machine with Qt Creator 3.2.2 (QT 4.8.6) when installing nvidia video driver. The symptoms I recognized:
    ---Programs compile within Qt Creator
    ---Programs started outside Qt Creator runs without any problem
    ---Programs started inside Qt Creator (by pushing the run button) start, but do not work properly (most of the time nothing or a frozen background is shown) with the following terminal output ("Draw method called" is printed by the program when the draw method is called)

    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast
    X Error: GLXBadContext 169
    Extension: 154 (Uknown extension)
    Minor opcode: 6 (Unknown request)
    Resource id: 0xba00010
    X Error: BadValue (integer parameter out of range for operation) 2
    Extension: 154 (Uknown extension)
    Minor opcode: 3 (Unknown request)
    Resource id: 0x0
    QGLContext::makeCurrent(): Failed.
    Draw Method called
    X Error: GLXBadDrawable 171
    Extension: 154 (Uknown extension)
    Minor opcode: 11 (Unknown request)
    Resource id: 0xba00012
    X Error: GLXBadContext 169
    Extension: 154 (Uknown extension)
    Minor opcode: 5 (Unknown request)
    Resource id: 0xba00010
    X Error: 0 0
    Extension: 154 (Uknown extension)
    Minor opcode: 26 (Unknown request)
    Resource id: 0x0
    QGLContext::makeCurrent(): Failed.
    Draw Method called
    ...

    I found a work around by adding a new run configuration of type user defined executable file with the binary file of the program as executable file.

    If anyone could figure out what is going on there it would be great to find a fix for it.

    Kind regards
    noone


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.