Important: Please read the Qt Code of Conduct -

No service found (mediaplayer) in Ubuntu 14.04

  • Hi everyone.

    I'm trying to execute some mediaplayer examples based on qml, but I'm having several problems when running applications that depend on the mediaplayer module.

    These are the details of my OS and my system:

    • Ubuntu 14.04, 32 bits
    • Qt5.5 Installed by QtCreator installator online QtCreator installator for Linux 32bits. I have Installed the default Qt5.5 options, all Tools and all QtExtras. The folder containing Qt is /home/user/Qt/

    Other developers solved his problem by installing gstreamer libraries, although this solution didn't work for me. Currently, I've installed in my computer the following dependencies:

    I've read that the error might be due to a missing library but checking the mediaservice plugin in my Qt folder I found:


    After configuring, compiling and running the default Qt example (QML Video Example) when I try to play a video, the output is:

    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"
    qml: [qmlvideo] VideoItem.onError error 5 errorString The QMediaPlayer object does not have a valid service
    qml: [qmlvideo] Content.onFatalError

    This is the output with QT_DEBUG_PLUGINS=1:

    Thank you,

  • Would it be possible that Qt couldn't to find gstreamer library because this one is installed in /usr/lib/i386-linux-gnu/gstreamer-0.10/. instead of in my Qt installation path in /home/user/Qt ?

    Thank you,

  • I provide more information. In this case I used ldd command with files below:


    $ ldd ~/Qt/5.5/gcc/plugins/mediaservice/ =>  (0xb77dd000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb76ed000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb7039000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb6ea7000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb695e000) => /usr/lib/i386-linux-gnu/mesa/ (0xb68a0000) => /lib/i386-linux-gnu/ (0xb6884000) => /usr/lib/i386-linux-gnu/ (0xb679b000) => /lib/i386-linux-gnu/ (0xb6755000) => /lib/i386-linux-gnu/ (0xb6738000) => /lib/i386-linux-gnu/ (0xb6589000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb6310000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb6167000) => /home/user/Qt/5.5/gcc/plugins/mediaservice/./../../lib/ (0xb493c000) => /lib/i386-linux-gnu/ (0xb4937000) => /usr/lib/i386-linux-gnu/ (0xb4934000) => /lib/i386-linux-gnu/ (0xb492b000) => /lib/i386-linux-gnu/ (0xb481e000)
    /lib/ (0xb77e0000) => /lib/i386-linux-gnu/ (0xb47f5000) => /usr/lib/i386-linux-gnu/ (0xb47dc000) => /usr/lib/i386-linux-gnu/ (0xb47c9000) => /usr/lib/i386-linux-gnu/ (0xb47c5000) => /usr/lib/i386-linux-gnu/ (0xb47be000) => /usr/lib/i386-linux-gnu/ (0xb47bb000) => /usr/lib/i386-linux-gnu/ (0xb4687000) => /usr/lib/i386-linux-gnu/ (0xb466f000) => /usr/lib/i386-linux-gnu/ (0xb4669000) => /usr/lib/i386-linux-gnu/ (0xb4664000) => /usr/lib/i386-linux-gnu/ (0xb4660000) => /usr/lib/i386-linux-gnu/ (0xb4659000) => /usr/lib/i386-linux-gnu/ (0xb4637000) => /usr/lib/i386-linux-gnu/ (0xb4634000) => /usr/lib/i386-linux-gnu/ (0xb462d000) => /usr/lib/i386-linux-gnu/ (0xb461e000) => /lib/i386-linux-gnu/ (0xb45e0000) => /usr/lib/i386-linux-gnu/ (0xb45dc000) => /usr/lib/i386-linux-gnu/ (0xb45d4000)


    $ ldd ~/Qt/5.5/gcc/lib/ =>  (0xb77c6000) => /home/user/Qt/5.5/gcc/lib/ (0xb7554000) => /home/user/Qt/5.5/gcc/lib/ (0xb6ea0000) => /home/user/Qt/5.5/gcc/lib/ (0xb6957000) => /lib/i386-linux-gnu/ (0xb690f000) => /usr/lib/i386-linux-gnu/mesa/ (0xb687d000) => /usr/lib/i386-linux-gnu/ (0xb6795000) => /lib/i386-linux-gnu/ (0xb674e000) => /lib/i386-linux-gnu/ (0xb6731000) => /lib/i386-linux-gnu/ (0xb6582000) => /home/user/Qt/5.5/gcc/lib/ (0xb6309000) => /home/user/Qt/5.5/gcc/lib/ (0xb6161000) => /home/user/Qt/5.5/gcc/lib/ (0xb4935000) => /lib/i386-linux-gnu/ (0xb4930000) => /usr/lib/i386-linux-gnu/ (0xb492d000) => /lib/i386-linux-gnu/ (0xb4924000) => /lib/i386-linux-gnu/ (0xb4818000)
    /lib/ (0xb77c9000) => /lib/i386-linux-gnu/ (0xb47ee000) => /usr/lib/i386-linux-gnu/ (0xb47d5000) => /usr/lib/i386-linux-gnu/ (0xb47c2000) => /usr/lib/i386-linux-gnu/ (0xb47be000) => /usr/lib/i386-linux-gnu/ (0xb47b8000) => /usr/lib/i386-linux-gnu/ (0xb47b4000) => /usr/lib/i386-linux-gnu/ (0xb4680000) => /usr/lib/i386-linux-gnu/ (0xb4668000) => /usr/lib/i386-linux-gnu/ (0xb4662000) => /usr/lib/i386-linux-gnu/ (0xb465e000) => /usr/lib/i386-linux-gnu/ (0xb4659000) => /usr/lib/i386-linux-gnu/ (0xb4652000) => /usr/lib/i386-linux-gnu/ (0xb4630000) => /usr/lib/i386-linux-gnu/ (0xb462d000) => /usr/lib/i386-linux-gnu/ (0xb4627000) => /usr/lib/i386-linux-gnu/ (0xb4617000) => /lib/i386-linux-gnu/ (0xb45d9000) => /usr/lib/i386-linux-gnu/ (0xb45d5000) => /usr/lib/i386-linux-gnu/ (0xb45ce000)

  • Solved using version 5.4.2..
    Should to exist a bug with missing libraries for Qt 5.5 version