QtWebKit 5.5.1 module fails to build



  • Hello,

    I'm trying to install Qt5 as part of a Python installation on our computer cluster. The Python GUI tools we use require QtWebKit (and submodules), so I'm trying to install v5.5.1 instead of v5.6. However, QtWebKit does not seem to build by default (although I don't see any error messages, and the other modules seem to build fine). Is there some configuration flags I forgot to set, or extra libraries I need, to get this module to build?

    Any help would be greatly appreciated!
    Thanks!



  • Hello again,

    Just wondering if anyone had a chance to look at this yet.
    Hopefully this is a matter of setting some configuration flags and/or installing some extra supporting libraries...

    Thanks!



  • First of all, instead of 5.5.1 these days you should build 5.6.1, using qtwebkit sources from [1].

    See [2] for dependencies that you need to install in order to build QtWebKit.

    [1] http://download.qt.io/community_releases/5.6/5.6.1/
    [2] http://wiki.qt.io/Building_Qt_5_from_Git


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.