QtCreator hangs due to overly-broad file monitoring. Even when "disabled."



  • I love using Qt Creator but I've identified what may be a fatal flaw.

    At work my home directory is an nfs mount using autofs. That is, rather than having my home directory locally on the computer, my home is a symlink:

    /u/aleeper -> /wg/stor2a/aleeper

    where /u -> /wg/u is a directory that contains symlinks for all other users home directories.

    The problem is that some people in the company change their symlink on /u to point NOT to the servers, but to their own machine. When one of these machines is down/off for whatever reason, this breaks those symlinks.

    This causes a MAJOR problem for QtCreator, because of what I believe is a faulty or overly-broad file-monitoring strategy. I have been able to reliably tell when a symlink is broken because QtCreator will hang for 30-60 seconds every time I try to do anything involving a file, such as switch to a different file in a project, presumably because it is waiting for the directory crawl to timeout. This renders the program completely unusable.

    This seems to imply that the file monitoring (or some other process) that Qt does is overly broad. It is searching not just my home directory, but also the parent of my home, which is the folder containing all those symlinks. I would love to be able to disable this behavior.

    I tried disabling the file monitoring by setting Tools->Options->Environment->General->"When files are externally modified" to "Ignore Modifications"," but this does not help. Either the file monitoring is happening anyway but being ignored, or there is another process in Qt that does this directory crawling.

    Any help? Is this a known bug? Or a "feature"? I tried switching to Eclipse but I don't like it. :p



  • Ya.. I don't like Eclipse much either ;) ... and your problem sounds fresh and interesting! Never worked in such a setup.. You're best off reporting a bug leaving this to the professionals.. I cannot find a related bug with a normal search.. "Bug Portal":http://bugreports.qt.nokia.com/


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.