Error compiling QT4 with VS2015



  • I want to compile QT 4.8.6 with VS2015 using the provided configure.exe and then nmake, but get the following errors when javascriptcore is been made:

    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\cstdint(23): error C2039: 'int_least8_t': is not a member of 'global namespace''
    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\cstdint(23): error C2873: 'int_least8_t': symbol cannot be used in a using-declaration
    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\cstdint(23): error C2039: 'int_least16_t': is not a member of 'global namespace''
    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\cstdint(23): error C2873: 'int_least16_t': symbol cannot be used in a using-declaration
    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\cstdint(24): error C2039: 'int_least32_t': is not a member of '`global namespace''
    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE\cstdint(24): error C2873: 'int_least32_t': symbol cannot be used in a using-declaration

    I found another page talking about this exact issue months ago, but unfortunately the compilation still fails despite the patching. Any idea what I could do to compile it ?
    Thanks.



  • Why Qt 4.8.6 and not the latest Qt 4.8.7 ?
    I've compiled Qt 4.8.7 with VS2010, VS2013 and VS2015, in 32 and 64 bits, here's my steps:
    https://github.com/sandym/qt-patches/tree/master/windows/qt-4.8.7


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.