QSsl Threaded



  • So I am trying to use QSslSocket to connect to a local server, code is available here: https://github.com/VSRonin/ThreadedQSSL
    You will have to create your own server.key SSL key file and server.crt SSL certificate file but the rest is ready to run.
    What I get when I run it is the client connecting but then never emitting encrypted. It just keeps hanging there. any idea why?



  • Ok, let's try and simplify this.
    First of all I'd like to know if it's a programming error or a deployment/configuration error.

    Could any of you just clone the repo, run qmake make, move to the release folder, create the key and certificate file there and run the program?

    This is the output I get, I never get "Client Encrypted". is it the same for you?

    Client State Changed  QAbstractSocket::HostLookupState
    Client State Changed  QAbstractSocket::ConnectingState
    Client State Changed  QAbstractSocket::ConnectedState
    Client Connected
    


  • I was not passing the passkey to the QSslKey
    Problem solved now


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.