I can't find the Example Demos



  • I can't find the example demo in my QT installation.

    But I've installed it, as I can see it in the Maintain QT SDK.
    !http://i39.photobucket.com/albums/e179/iamcreasy/Untitled-2.jpg(Pic)!

    They are not under the Qt 4 submenu. As stated in the doc.



  • Now that seems odd...



  • You can always find them in the Examples subfolder of your QtSDK installation.



  • Yeh, the sources are there. But I was looking for an executable which allows the user to test the examples without going through the building process.

    I have used QT before, but that a long time ago. Then, it came with compiled examples.


  • Moderators

    There is no executable for qtdemo anymore in the sdk.

    But as you have choosen to install them you should find a map with the sources and a .pro file.

    Your other choice is using qt Creator's welcome screen. That way you can open the same sources and compile there.

    It's a pity they are not installed anymore because they help a lot to find the right examples.



  • Is there any script or make file, using which, I can batch compile all of those? and make a single executable before, like what QT provided before.


  • Moderators

    I haven't done it myself because i still have an old installation with the executable.

    But you should be able to compile it using
    @qmake -project
    make
    Install@
    In the directory where you find the qtdemo.pro file.(is that the correct Filename?,i'm just posting from my mobile wihout the sources at hand)



  • I tried to build the example (in QT Creator, Build > Build Project "examples") opening the examples.pro, but it gave me the following 4 warnings and errors.

    Warning:
    C:\QtSDK\Examples\examples-build-desktop\graphicsview\portedasteroids......\4.7\graphicsview\portedasteroids\ledmeter.cpp:-1: In member function 'virtual void KALedMeter::paintEvent(QPaintEvent*)':

    C:\QtSDK\Examples\examples-build-desktop\graphicsview\portedasteroids......\4.7\graphicsview\portedasteroids\ledmeter.cpp:146: warning: comparison between signed and unsigned integer expressions

    Error
    :-1: error: cannot find -lpnp_basictoolsd

    :-1: error: collect2: ld returned 1 exit status

    and it stopped.

    Why there would be any error.

    Edit : Im gonna try with the demos.pro



  • I tried with, demos.pro, it gives me the following error,

    C:\QtSDK\Demos\demos-build-desktop\shared....\4.7\shared\arthurwidgets.cpp:54: error: private/qpixmapdata_p.h: No such file or directory

    this shouldn't be! :(



  • Same here regarding the demos (I didn't investigate any further though)



  • got an idea, I can install the old version to get the demos. :D

    but, that's not a solution anyway :P

    @loladiro do you face the same thing for both examples.pro and demos.pro

    there is another qtdemo.pro inside Demos/qtdemos, but it doesn't compile too.



  • @loladiro @creasy.. Let me clear this up.. AFAIK this is a difference in Qt sources in Linux and Windows. In linux, we have a seperate include folder with the headers.. The private folder in this include seems to exist in QtSDK/Desktop/Qt/471/gcc/ and QtSDK/Desktop/Qt/472/gcc/ but not the 473.



  • Ok, -the examples are compiling without any problem and- the demo error is a "known bug":http://bugreports.qt.nokia.com/browse/QTSDK-636

    Edit: @jim_kaiser: How come you always post when I'm just writing mine. But you're right, it is platform dependent (see also the bugreport I linked to). However, I still think that linking to private headers is bad practice since those are not part of the public API and can be changed or removed.

    EDIT2: Correction. I was a little early to claim the examples were compiling. In fact I get the same error.



  • But hey... i just compiled the qtdemo.pro and it worked. Qt Creator 2.2.0 .. SDK 1.1.1

    [Edit: Sorry.. I assumed we were talking about Linux.. Works in Linux. In Windows I should check.. tomorrow at work! But yeah mostly it should just be about adding an include directory maybe..]
    [Edit again: Okay known bug... I shall rest..]



  • I'm on Linux (Ubuntu), but according to the bug report, the private header file is not needed on Windows.



  • @loladiro: It doesn't compile on linux for you? Works for me.. And hehe... we do tend to post simultaneously! And yeah the private files are probably not needed.. We do link to one in our application at work... but we also maintain our patch in the related classes each version.. so thats okay :P. Could you check if using "QtGui/private/qpixmapdata_p.h" works? In case the sub dirs are not added in the include path. But if not needed on Windows as the bug report says.. can be commented i presume.



  • yeh, commented it out and with 4 warnings it compiles successfully. But, the output folder has a Makefile and a lot of other folders in it.

    Now what to do?



  • If the compile completed successfully.. there should be an exe in the QtSDK/Demos/bin..?

    [Edit: On compiling the qtdemo.pro through QtCreator for desktop target, the exe was generated in that location..]



  • No bin folder is there. But, I guess the compiler's setting is different here.

    Files are I guess here,

    Demos\demos-build-desktop\browser\release

    I have some *.exe files.(Demos\demos-build-desktop\browser\release\browser.exe) but, whenever I try to run any executable, I get the following error,

    "The program cann't start because mingwm10.dll is missing form your computer. Try reinstalling the program to fix this problem."



  • I added "C:\QtSDK\mingw\bin;C:\QtSDK\Desktop\Qt\4.7.3\mingw\bin;" to windows PATH, now things are working fine.But, 2 issues

    1. No dedicated OpenGL Examples as they were before
    2. No global example browsing context.

    :-s



  • Same problem here :(
    I think dropping qtDemo.exe from the SDK is a bad idea. Right now, I'm using the same workaround as iamcreasy ; 4.7.3 for the actual work, 4.7.1 for the demos.



  • This is very creepy. :(

    I was even thinking about switching back to older version for using the working OpenGL Examples.

    "OpenGL Cube Example doesn't run":http://developer.qt.nokia.com/forums/viewthread/6884

    But, still Im not sure, if the older versions, support OpenGL 3.3 or greater context.

    any thoughts?


  • Moderators

    People keep on asking about this. so i searched the bug tracker to add a suggestion but there is already a bug report for the missing qtdemo http://bugreports.qt.nokia.com/browse/QTSDK-780



  • They should integrate the compiled demo like they did before. It may increase the download size but, for windows its already 1.5gb, an extra 200mb wont cause any trouble.



  • At least make it an optional download would be good thing.
    [quote author="iamcreasy" date="1309528030"]They should integrate the compiled demo like they did before. It may increase the download size but, for windows its already 1.5gb, an extra 200mb wont cause any trouble.[/quote]



  • I am not sure if this is what you are looking for but today i bumped into "this":http://gitorious.org/~agateau/qt/agateau-qt ..
    You can download all qt examples/demos.. Just click at the source tree and then download the tar.gz file



  • Hi, I have the all examples, demos and qtdemo compiled successfully (with some tricks) in ubuntu. When I lunch the the qtdemo binary in "QtSdk\Demo\bin" directory I see the list of programs available but I cannot lunch them. I get the error "Could not lunch the example, ensure that it is built". I am sure that they are compiled, I can lunch them manually from their source directories. Also the descriptions are missing. I see the warning "Could not load description. Ensure that documentation for Qt is built". I have this problem both in the versions 4.7.3 and 4.7.4. I have this problem also in the windows environment. Any ideas about this?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.